Autore Topic: Admob non carica più ads  (Letto 664 volte)

Offline trevo92

  • Nuovo arrivato
  • *
  • Post: 12
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy S
  • Sistema operativo:
    Windows 7
Admob non carica più ads
« il: 13 Novembre 2012, 09:12:43 CET »
0
Ciao a tutti. Come da titolo ho un problema con gli ads.
La mia applicazione fino a 1 mese fa carica tranquillamente gli ads con la sdk 6.1.0 mentre ora la stessa applicazione,senza aver modificato nulla, non carica più nulla. Qualche idea?

Nello specifico ricevo questo errore:

Codice (logcat): [Seleziona]
ReferenceError: AFMA_getSdkConstants is not defined (about:blank:1)
E/Web Console(11448): Uncaught ReferenceError: AFMA_getSdkConstants is not defined at about:blank:1

EDIT: L'errore si verifica solo con android 4.x
« Ultima modifica: 13 Novembre 2012, 14:33:24 CET da trevo92 »

Offline warko

  • Nuovo arrivato
  • *
  • Post: 10
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    galaxy S2
  • Sistema operativo:
    windows 7
Re:Admob non carica più ads
« Risposta #1 il: 02 Aprile 2013, 00:06:23 CEST »
0
ciao,
io ho lo stesso problema, hai risolto?

io sto usando le api level 13 e lo testo direttamente su uno smartphone con jelly bean.
l'errore ceh si presenta è il seguente:
04-02 00:39:58.935: E/Ads(7666): JS: Uncaught ReferenceError: AFMA_getSdkConstants is not defined (http://media.admob.com/:1)

logcat:
Codice: [Seleziona]
04-02 00:39:58.675: I/webclipboard(7666): clipservice: android.sec.clipboard.ClipboardExManager@42ee4050
04-02 00:39:58.735: V/webkit(7666): BrowserFrame constructor: this=Handler (android.webkit.BrowserFrame) {42edec08}
04-02 00:39:58.770: I/webclipboard(7666): clipservice: android.sec.clipboard.ClipboardExManager@42ee4050
04-02 00:39:58.775: V/webkit(7666): BrowserFrame constructor: this=Handler (android.webkit.BrowserFrame) {42f514e8}
04-02 00:39:58.780: V/webkit(7666): BrowserFrame constructor: this=Handler (android.webkit.BrowserFrame) {42f59d48}
04-02 00:39:58.785: I/Ads(7666): To get test ads on this device, call adRequest.addTestDevice("D477D538EA5B0768C428B51ABF46B217");
04-02 00:39:58.810: I/Ads(7666): adRequestUrlHtml: <html><head><script src="http://media.admob.com/sdk-core-v40.js"></script><script>AFMA_getSdkConstants();AFMA_buildAdURL({"preqs":0,"session_id":"9320955224311339339","u_sd":1.5,"seq_num":"1","slotname":"a151597725e2cd2","u_w":320,"msid":"alphamale.namespace","js":"afma-sdk-a-v6.3.1","ms":"hOydJIDiyHufYDGmSvcBO6MbciY6Hbg2J5rsa-eyigUfSID0xi1sXP34fTfVTodsO0MbRWElQZWGtJbUiTC2ATlDfd8CF4MpNojXllwwdbLx6rqDZkoYNh-L6BpnH-HfwQSiCCE5PdQvEU0KcPtz5UF77nSzI6dF0V3ob7zw1gTKifobbEfg5uRMdF9Bnw8TVK-Ra_5IFfgQJQDR-b61YHZaJFeb11zjH3HcFGmKIAoc0RSkj0xaxUXikW3dtkiiATnR0cJ57NW9lfrCpJbffk9VVc_el2Tld1mbkqLV-orss-CRElW8wP5BaN6vmdHyW2EsA5l6Ixiv5AXx22MtBQ","mv":"8016014.com.android.vending","isu":"D477D538EA5B0768C428B51ABF46B217","bas_off":0,"format":"320x50_mb","oar":0,"net":"null","app_name":"1.android.alphamale.namespace","hl":"it","ad_pos":{"height":0,"visible":0,"y":0,"x":0,"width":0},"gnt":8,"u_h":533,"pt":1,"carrier":"22201","bas_on":0,"ptime":0,"u_audio":1});</script></head><body></body></html>
04-02 00:39:58.905: E/SpannableStringBuilder(7666): SPAN_EXCLUSIVE_EXCLUSIVE spans cannot have a zero length
04-02 00:39:58.910: E/SpannableStringBuilder(7666): SPAN_EXCLUSIVE_EXCLUSIVE spans cannot have a zero length
04-02 00:39:58.935: E/Ads(7666): JS: Uncaught ReferenceError: AFMA_getSdkConstants is not defined (http://media.admob.com/:1)
04-02 00:39:58.935: I/GATE(7666): <GATE-M>DEV_ACTION_COMPLETED</GATE-M>
04-02 00:39:58.935: E/Web Console(7666): Uncaught ReferenceError: AFMA_getSdkConstants is not defined:1
04-02 00:40:00.205: D/SensorManager(7666): registerListener :: handle = 0  name= K3DH Acceleration Sensor delay= 66667 Trklfufi 9 bthpbvbtf5ubvfkhbcf5KpbsfFmfulTrklfufi@,)8.d8:(
04-02 00:40:58.785: I/Ads(7666): AdLoader timed out after 60000ms while getting the URL.
04-02 00:40:58.790: D/webviewglue(7666): nativeDestroy view: 0x51388c48


a qualcuno è capitato un problema simile? forse con jelly bean...
« Ultima modifica: 02 Aprile 2013, 00:45:52 CEST da warko »

Offline trevo92

  • Nuovo arrivato
  • *
  • Post: 12
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy S
  • Sistema operativo:
    Windows 7
Re:Admob non carica più ads
« Risposta #2 il: 02 Aprile 2013, 10:21:26 CEST »
0
Io alla fine se non ricordo male ho scoperto che il problema era dato dalla mia rom che bloccava gli ads di google delle applicazioni. Ho scaricato adaway e ho ripristinato la situazione. Fossi in te proverei l'applicazione su cellulari diversi per capire se il problema è del telefono o dell'app.