Autore Topic: problemi installazione sherlockbar  (Letto 552 volte)

Offline branco

  • Nuovo arrivato
  • *
  • Post: 19
  • Respect: 0
    • Mostra profilo
problemi installazione sherlockbar
« il: 12 Ottobre 2012, 18:49:40 CEST »
0
salve a tutti,
non mi funziona sherlockbar, vi dico il procedimento che ho seguito...ditemi dove sbaglio

scaricata la versione nuova e scompattata
in eclipse file-->import-->android-->existing code into workspace-->browse--->seleziono la sola cartella library
check sulla copia file all'interno workspace e finish

adesso vado in library-->libs > android-support-v4.jar (clic destro > Build Path > Add to Build Path)

adesso vado nel mio progetto
destro-->propietà--->android in fondo in libreria new e seleziono library(unica selezionabile)

nel mio progetto non ci sono errori mentre nel progetto library ogni file ne ha mille mila.
vado a vedere gli errori e ho notato che levando gli @overraide gli errori scompaiono
essendo tantissimi non posso mettermi a farlo a mano quindi devo avere sbagliato da quelche parte.

grazie

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +507
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:problemi installazione sherlockbar
« Risposta #1 il: 12 Ottobre 2012, 19:05:10 CEST »
0
salve a tutti,
non mi funziona sherlockbar, vi dico il procedimento che ho seguito...ditemi dove sbaglio

scaricata la versione nuova e scompattata
in eclipse file-->import-->android-->existing code into workspace-->browse--->seleziono la sola cartella library
check sulla copia file all'interno workspace e finish

adesso vado in library-->libs > android-support-v4.jar (clic destro > Build Path > Add to Build Path)

adesso vado nel mio progetto
destro-->propietà--->android in fondo in libreria new e seleziono library(unica selezionabile)

nel mio progetto non ci sono errori mentre nel progetto library ogni file ne ha mille mila.
vado a vedere gli errori e ho notato che levando gli @overraide gli errori scompaiono
essendo tantissimi non posso mettermi a farlo a mano quindi devo avere sbagliato da quelche parte.

grazie

Se hai una versione recente dell'ADT non serve che aggiungi "android-support-v4.jar" al build path. E' sufficiente che la lasci nella cartella libs e lui la prende automaticamente.

Per il tuo problema io verificherei le seguenti cose:
- che il target del progetto sia selezionato. Nella libreria vai in Project -> Properties -> Android (tieni conto che devi dargli come target l'api level 15 o 16).
- che il compilatore usato sia quello della versione 1.6 (Project -> Properties -> Java Compiler)

Verifica queste cose e poi fai un bel Project -> Clean di tutto.