Autore Topic: cambiare interfaccia di rete all'emulatore  (Letto 860 volte)

Offline Pol

  • Nuovo arrivato
  • *
  • Post: 49
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    s2
  • Sistema operativo:
    debian
cambiare interfaccia di rete all'emulatore
« il: 08 Ottobre 2012, 17:43:10 CEST »
0
ciao a tutti, leggendo la guida ufficiale android non mi è ancora chiaro come posso cambiare l'interfaccia di rete all'emulatore:

è in ascolto su quella di loopback

io sviluppo su win (dato che eclipse su linux ha diversi bug) ma l'emulatore sta su un pc della lan su linux.

Ho visto che si può cambiare la porta e fare il forward ma ancora non ho capito come cambiare interfaccia di rete

qualcuno che l'ha fatto?

grazie!
Pol

Offline iceweasel

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 878
  • Respect: +147
    • Mostra profilo
  • Dispositivo Android:
    LGE P990 - Google Nexus 5
  • Sistema operativo:
    Linux Debian Sid
Re:cambiare interfaccia di rete all'emulatore
« Risposta #1 il: 08 Ottobre 2012, 18:51:14 CEST »
0
dato che eclipse su linux ha diversi bug

Bug ? Da esperto utente Linux dimmi quali sono questi bug ?

Il port forward si fa' col comando "adb", help da linea di comando spiega come fare o basta leggere la documentazione ufficiale:

Android Debug Bridge | Android Developers
adb logcat | tee /tmp/logcat | grep TAG

Offline Pol

  • Nuovo arrivato
  • *
  • Post: 49
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    s2
  • Sistema operativo:
    debian
Re:cambiare interfaccia di rete all'emulatore
« Risposta #2 il: 08 Ottobre 2012, 19:32:34 CEST »
0
Pol

Offline iceweasel

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 878
  • Respect: +147
    • Mostra profilo
  • Dispositivo Android:
    LGE P990 - Google Nexus 5
  • Sistema operativo:
    Linux Debian Sid
Re:cambiare interfaccia di rete all'emulatore
« Risposta #3 il: 08 Ottobre 2012, 20:03:14 CEST »
0
Basta non usare la versione 4.2, anch'io dico che non è un IDE stabile.

La versione di Eclipse consigliata da Google per programmare Android è la 3.6.2 in sù ma i plugin hanno problemi con Eclipse 4.x. Basta installare una versione stabile e quei bug non sono presenti, io uso la versione 3.7.
adb logcat | tee /tmp/logcat | grep TAG