Autore Topic: Eclipse IDE for Java EE Developers  (Letto 1170 volte)

Offline Andronico

  • Nuovo arrivato
  • *
  • Post: 23
  • Respect: 0
    • Mostra profilo
Eclipse IDE for Java EE Developers
« il: 01 Ottobre 2012, 09:51:28 CEST »
0
Salve a tutti, ho installato l'ultima versione di Eclipse IDE for Java EE Developers; in seguito ho installato il plugin per Android da https://dl-ssl.google.com/android/eclipse/ e ho riavviato; volevo scrivere il mio primo programma per Android, ma se seleziono File -> New ... non trovo nessun riferimento per un nuovo progetto Android. Dove ho sbagliato?

Grazie

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Eclipse IDE for Java EE Developers
« Risposta #1 il: 01 Ottobre 2012, 10:25:35 CEST »
0
Hai seguito qualche tutorial?
E quali versioni hai installato di preciso? Parlo di Java SDK, di Eclipse e quali API versions hai scaricato.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline Andronico

  • Nuovo arrivato
  • *
  • Post: 23
  • Respect: 0
    • Mostra profilo
Re:Eclipse IDE for Java EE Developers
« Risposta #2 il: 01 Ottobre 2012, 10:43:39 CEST »
0
Ciao Bradipao,

      ho seguito questa guida: How to Install Android SDK and Get Started

1 - ho installato JDK;
2 - ho installato l'SDK con tutte le API dalla prima fino all'ultima;
3- ho installato Eclipse IDE for Java EE Developers;
4- ho installato il plugin per Android;
5- ho riavviato.

Come ho detto prima in Eclipse non ho nessun riferimento ad Android. Cosa ho sbagliato?

Andronico
« Ultima modifica: 01 Ottobre 2012, 10:46:06 CEST da Andronico »

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Eclipse IDE for Java EE Developers
« Risposta #3 il: 01 Ottobre 2012, 10:53:08 CEST »
0
3- ho installato Eclipse IDE for Java EE Developers;

Che versione?
Sei sicuro che l'installazione sia andata a buon fine? Se controlli nella lista dei plugin installati, lo vedi?

Offline Andronico

  • Nuovo arrivato
  • *
  • Post: 23
  • Respect: 0
    • Mostra profilo
Re:Eclipse IDE for Java EE Developers
« Risposta #4 il: 01 Ottobre 2012, 11:04:55 CEST »
0
Ciao Ricky,

Eclipse Java EE IDE for Web Developers.

Version: Juno Service Release 1
Build id: 20120920-0800

Ho cercato i plugin, vedo una sfilza infinita di tools, ma Android non lo vedo. Se vado su Preferences per indicargli la cartella relativa all'sdk, la voce Android non c'è per niente. Se provo a reinstallare il plugin, mi dice che sono al completo ...

 
« Ultima modifica: 01 Ottobre 2012, 11:11:48 CEST da Andronico »

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Eclipse IDE for Java EE Developers
« Risposta #5 il: 01 Ottobre 2012, 11:13:20 CEST »
0
Eclipse a volte è un po' strano. Comunque, giusto per fare una prova... scarica la versione classic ed installa il plugin:
Eclipse Classic 4.2.1 | Eclipse Packages

Se non ti servono particolari plugin della versione per Java EE (e se sviluppi Android NON ti servono), la classic è anche più leggera :)

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Eclipse IDE for Java EE Developers
« Risposta #6 il: 01 Ottobre 2012, 11:16:55 CEST »
+1
1 - ho installato JDK;

Quale versione? Spero non la 7.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline Andronico

  • Nuovo arrivato
  • *
  • Post: 23
  • Respect: 0
    • Mostra profilo
Re:Eclipse IDE for Java EE Developers
« Risposta #7 il: 01 Ottobre 2012, 11:22:22 CEST »
0
Grazie Ricky ci avevo già pensato anche perché in fondo eclipse è una cartella scompattata;

a Bradipao volevo dire che nella cartella Java vedo due sottocartelle: jdk 1.7.0_04 e jre7 ... come risolvo?

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Eclipse IDE for Java EE Developers
« Risposta #8 il: 01 Ottobre 2012, 11:27:51 CEST »
0
a Bradipao volevo dire che nella cartella Java vedo due sottocartelle: jdk 1.7.0_04 e jre7 ... come risolvo?

Devi mettere la JDK 6.

Se vedi qua ( Android SDK | Android Developers ) nella sezione System Requirement, ci sono le indicazioni sulle versioni da installare.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline Andronico

  • Nuovo arrivato
  • *
  • Post: 23
  • Respect: 0
    • Mostra profilo
Re:Eclipse IDE for Java EE Developers
« Risposta #9 il: 01 Ottobre 2012, 11:30:11 CEST »
0
Grazie a tutti per avermi aiutato ... se lascio la 7 posso seguire il consiglio di Ricky passando alla versione classica di Eclipse?


Offline Andronico

  • Nuovo arrivato
  • *
  • Post: 23
  • Respect: 0
    • Mostra profilo
Re:Eclipse IDE for Java EE Developers
« Risposta #10 il: 01 Ottobre 2012, 12:42:18 CEST »
0
Ho risolto come suggerito da Ricky. Ho scaricato la versione classic di Eclipse e installato il plugin per Android.

Grazie