Autore Topic: Errore Failed to load libGL.so in debian 64 bit ed Eclipse Indigo  (Letto 1357 volte)

Offline jocker99

  • Nuovo arrivato
  • *
  • Post: 39
  • Respect: +2
    • Mostra profilo
  • Dispositivo Android:
    samsung galaxy mini 2
  • Sistema operativo:
    debian 6 - 64 bit
0
Salve ragazzi e grazie mille per i vostri aiuti:
Dopo aver aggiornato avd, quando lancio l'emulatore dalla console ho questo messaggio
Codice: [Seleziona]
2012-08-10 09:23:45 - test3] Android Launch!
[2012-08-10 09:23:45 - test3] adb is running normally.
[2012-08-10 09:23:45 - test3] Performing com.example.test3.MainActivity activity launch
[2012-08-10 09:23:45 - test3] Automatic Target Mode: launching new emulator with compatible AVD 'emulator_10'
[2012-08-10 09:23:45 - test3] Launching a new emulator with Virtual Device 'emulator_10'
[2012-08-10 09:23:51 - Emulator] Failed to load libGL.so
[2012-08-10 09:23:51 - Emulator] error libGL.so: cannot open shared object file: No such file or directory
[2012-08-10 09:23:51 - Emulator] Failed to load libGL.so
[2012-08-10 09:23:51 - Emulator] error libGL.so: cannot open shared object file: No such file or directory
[2012-08-10 09:23:52 - Emulator] emulator: emulator window was out of view and was recentered

pero' l'emulatore funziona e tutto sembra funzionare bene, on line ho trovato qualcosa ma molto "approssimativo" voi avete qualche consiglio/dritta
Grazie mille

p.s. il mio pc e' una debian squize a 64 bit e' uso eclipse indago,

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Errore Failed to load libGL.so in debian 64 bit ed Eclipse Indigo
« Risposta #1 il: 10 Agosto 2012, 10:02:41 CEST »
0
Non ho la minima idea di cosa sia, ne' come risolvere, ma ho messo l'errore su google e sono usciti un po' di utenti che hanno avuto lo stesso errore ed hanno risolto in vari modi:
Failed to load libGL.so in android - Stack Overflow
Fixing Ubuntu Error: Failed to load libGL.so « Learned Stuff

Se questi non aiutano, cerca android Failed to load libGL.so in google e sfoglia i risultati.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline iceweasel

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 878
  • Respect: +147
    • Mostra profilo
  • Dispositivo Android:
    LGE P990 - Google Nexus 5
  • Sistema operativo:
    Linux Debian Sid
Re:Errore Failed to load libGL.so in debian 64 bit ed Eclipse Indigo
« Risposta #2 il: 10 Agosto 2012, 10:16:07 CEST »
0
L'emulatore Android non è in grado di emulare nessuna funzione OpenGL perché non prova le OpenGL sul PC. Conseguenze: se non usi le OpenGL-ES su Android nessuna.

Non hai installato nella tua distribuzione Linux una libreria OpenGL, di solito è fornita dal produttore della scheda video o si passa per una emulazione via CPU con le Mesa ma sono molto (molto molto) lente.
adb logcat | tee /tmp/logcat | grep TAG

Offline jocker99

  • Nuovo arrivato
  • *
  • Post: 39
  • Respect: +2
    • Mostra profilo
  • Dispositivo Android:
    samsung galaxy mini 2
  • Sistema operativo:
    debian 6 - 64 bit
Re:Errore Failed to load libGL.so in debian 64 bit ed Eclipse Indigo
« Risposta #3 il: 10 Agosto 2012, 12:20:21 CEST »
0
Dato che non uso OpenGL lascio tutto come adesso  :D ,
 cmq per chiarezza e aiuto agl'altri, continuando  io ho un portatile con una  ati  :-(  per l'esattezza una ATI Mobility Radeon™ HD 3650, i driver video li ho installati dal repositori ufficiali di debian, (ho seguito questo wiki ATIProprietary - Debian Wiki ) e per ora non ho avuto problemi.....

grazie a tutti
J.

Offline iceweasel

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 878
  • Respect: +147
    • Mostra profilo
  • Dispositivo Android:
    LGE P990 - Google Nexus 5
  • Sistema operativo:
    Linux Debian Sid
Re:Errore Failed to load libGL.so in debian 64 bit ed Eclipse Indigo
« Risposta #4 il: 10 Agosto 2012, 16:48:24 CEST »
0
Molto probabilmente l'emulatore di Android non riesce a trovare la libreria nelle solite directory. I vari fix che si leggono sono dei semplici link simbolici per aiutare l'emulatore a trovare la libreria (è di solito in /usr/lib/libGL.so).
adb logcat | tee /tmp/logcat | grep TAG