Autore Topic: Problemi installazione ambiente sviluppo Android - ADT per Eclipse  (Letto 3676 volte)

Offline pamide

  • Nuovo arrivato
  • *
  • Post: 14
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    tablet HTC Flyer
  • Sistema operativo:
    Mac OS X 10.5
0
Ciao!

Vi chiedo gentilmente aiuto perchè non riesco più ad installare ADT per Eclipse.
Lavoro su un Mac e ho installato in precedenza l'ambiente di sviluppo su 2 PC Windows e su questo Mac. Solo che ad un certo punto l'emulatore ci metteva una vita a partire e tante volte non partiva più. Ho tentato un aggiornamento e non ha funzionato più nulla. Eclipse dava errore.

Allora ho fatto diverse volte l'installazione. Va tutto a buon fine: eclipse, SDK e ADT. Solo che nelle preferenze non esiste la voce Android.
Ho seguito le istruzioni di installazione che dicevano di usare versioni superiori a 3.6.2 per Eclipse. Quindi ho installato:
SDK 20.0.1
Eclipse 4.2

C'è forse un problema di incompatibilità? Che versione mi consigliate?

Vi ringrazio per ogni suggerimento,
Miky

Offline jocker99

  • Nuovo arrivato
  • *
  • Post: 39
  • Respect: +2
    • Mostra profilo
  • Dispositivo Android:
    samsung galaxy mini 2
  • Sistema operativo:
    debian 6 - 64 bit
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #1 il: 28 Luglio 2012, 18:35:48 CEST »
0
Ciao, io non uso mac ma a causa della pesantezza del emulatore, in win 7 e' esasperante, sono passato a linux, che io sappia con eclipse non dovrebbero esserci problemi con il mac, dato che lo usa anche mio fratello e non ha mai avuto problemi, (ma non per programmare in android), quindi il problema potrebbe essere adt, io ti consiglio di cancellare eclipse e reinstallarlo da zero  compreso sdk

Offline pamide

  • Nuovo arrivato
  • *
  • Post: 14
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    tablet HTC Flyer
  • Sistema operativo:
    Mac OS X 10.5
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #2 il: 29 Luglio 2012, 14:34:07 CEST »
0
Come dicevo ho provato diverse volte a reinstallare tutto da capo. L'installazione dell'ADT va a bon fine, si riavvia ma non vede l'ADT. Avevo già usato Eclipse sullo stesso Mac.

C'è un posto dove posso vedere i plugin nel file system?
Dove si trova il log di avvio di Eclipse?

Grazie,
Miky

Offline iceweasel

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 878
  • Respect: +147
    • Mostra profilo
  • Dispositivo Android:
    LGE P990 - Google Nexus 5
  • Sistema operativo:
    Linux Debian Sid
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #3 il: 29 Luglio 2012, 15:30:02 CEST »
0
Apri un terminale (non so' come si chiama sotto MacOSX) e lancia Eclipse in questo modo:

Codice: [Seleziona]
eclipse -debug -consoleLog
abilita il debug mode e stampa nella console tutti i log.

P.S. Eclipse 4.2 non va' bene, molte funzioni non sono attive o hanno problemi, non è consigliata l'uso per i non esperti. Installa una versione 3.x, la minima versione per ADT 20.0.2 è la versione 3.6.2.

adb logcat | tee /tmp/logcat | grep TAG

Offline pamide

  • Nuovo arrivato
  • *
  • Post: 14
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    tablet HTC Flyer
  • Sistema operativo:
    Mac OS X 10.5
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #4 il: 31 Luglio 2012, 08:35:53 CEST »
0
Grazie mille!

Ho scaricato Eclipse 3.7.2 (indigo) come quella che avevo prima.  Va bene con SDK 20? Prima avevo una versione inferiore ma non mi ricordo quale.
ADT lo scarica lui usando il menu, quindi spero che si piglia la versione giusta.
Questa sera ci provo! Ho pensato anche di controllare l'esistenza dei plugin. Ho visto che c'è una cartella .plugin in Eclipse. Quando tento a reinstallare l'ADT mi dice, se non sbaglio i pachetti che tenta di installare. Vediamo! Sono ferma da 1 mese!

Grazie,
Miky

Offline iceweasel

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 878
  • Respect: +147
    • Mostra profilo
  • Dispositivo Android:
    LGE P990 - Google Nexus 5
  • Sistema operativo:
    Linux Debian Sid
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #5 il: 31 Luglio 2012, 09:28:26 CEST »
0
La 3.7.2 va' bene, importante è che sia maggiore di 3.6.2 e non la 4.x (fino a quando ADT non sarà ufficialmente compatibile con questa versione).

adb logcat | tee /tmp/logcat | grep TAG

Offline pamide

  • Nuovo arrivato
  • *
  • Post: 14
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    tablet HTC Flyer
  • Sistema operativo:
    Mac OS X 10.5
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #6 il: 31 Luglio 2012, 21:10:42 CEST »
0
neanche con la 3.7.2 non cambia nulla.
E lanciando dalla console non vedo nessun messaggio di errore.

Ma dove scrive i log?

Miky

Offline iceweasel

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 878
  • Respect: +147
    • Mostra profilo
  • Dispositivo Android:
    LGE P990 - Google Nexus 5
  • Sistema operativo:
    Linux Debian Sid
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #7 il: 31 Luglio 2012, 22:23:01 CEST »
0
Nessuno messaggio ?? molto strano, sotto Linux è molto prolisso.

I messaggi di log con l'opzione  "-consoleLog" sono scritti nella console o terminale (credo che sia ovvio).

Non hai specificato la versione di Java, serve la 1.6, assolutamente niente 1.7.
adb logcat | tee /tmp/logcat | grep TAG

Offline pamide

  • Nuovo arrivato
  • *
  • Post: 14
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    tablet HTC Flyer
  • Sistema operativo:
    Mac OS X 10.5
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #8 il: 02 Agosto 2012, 10:18:00 CEST »
0
Messaggi ci sono ma nessun messaggio di errore. Adesso non sapendo cosa dovrebbe scrivere magari non mi accorgo della mancanza di qualchè messaggio.

Aaah! Non sò che java ho messo ma credo di aver aggiornato all'ultima versione. Ho seguito le istruzioni da zero. Provo a disinstallare java e cercare la versione 1.6. Spero si trovi!

Grazie,
Miky

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #9 il: 02 Agosto 2012, 10:30:42 CEST »
0
Messaggi ci sono ma nessun messaggio di errore. Adesso non sapendo cosa dovrebbe scrivere magari non mi accorgo della mancanza di qualchè messaggio.

Aaah! Non sò che java ho messo ma credo di aver aggiornato all'ultima versione. Ho seguito le istruzioni da zero. Provo a disinstallare java e cercare la versione 1.6. Spero si trovi!

Grazie,
Miky

Ma hai davvero OSX 10.5??

Offline pamide

  • Nuovo arrivato
  • *
  • Post: 14
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    tablet HTC Flyer
  • Sistema operativo:
    Mac OS X 10.5
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #10 il: 02 Agosto 2012, 10:34:02 CEST »
0
Direi di si, perchè? Non va bene?
Ho anche Windows XP installato ma Eclipse era molto più stabile con Mac OSX. Ho fatto un corso di programmazione e tutti i miei colleghi, docente incluso avevano problemi. Andava spesso in crash. Il mio Mac no!

Mi tocca tentare a lavorare su Win. Boooh! :(  :-(

Grazie,
Miky
« Ultima modifica: 02 Agosto 2012, 10:39:03 CEST da pamide »

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #11 il: 02 Agosto 2012, 13:39:22 CEST »
0
Direi di si, perchè? Non va bene?
Ho anche Windows XP installato ma Eclipse era molto più stabile con Mac OSX. Ho fatto un corso di programmazione e tutti i miei colleghi, docente incluso avevano problemi. Andava spesso in crash. Il mio Mac no!

Va benissimo osx, ero però sorpreso dalla versione 10.5 che è un po' "datata". ;)

Comunque assicurati di avere Java 1.6 installata e impostata come di default ( Selecting Java Version on Mac OSX 10.5 (Leopard) ).

Offline pamide

  • Nuovo arrivato
  • *
  • Post: 14
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    tablet HTC Flyer
  • Sistema operativo:
    Mac OS X 10.5
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #12 il: 06 Agosto 2012, 10:13:25 CEST »
0
niente da fare!

Allora per la versione di java ho installato l'ultima. Java SE 1.5.0_30 e Java JDK 1.6.0_26.
Per Mac, Java viene fornita da Apple. L'ultima versione che ho trovato è questa.

Se do il commando "java -version" mi dice 1.5.0_30. Ho notato un link in una delle cartelle di Java: Current JDK -> 1.5
Mah!

Nelle Preferences di Java sono selezionate sia le versioni 1.5 che la 1.6. Se deseleziono le 1.5 non parte Eclipse.

Comunque io non credo che c'entri Java. Prima di fare l'aggiornamento funzionava! Secondo me la versione 1.20 di ADT non va bene per il mio sistema. Solo che non saprei come reperire e installare una versione anteriore. Lui mi scarica solo l'ultima!

Dalla prima finestra "splash" o come si chiama, sono arrivata ai log di installazione. Mi risultano installati correttamente tutti i plugin ADT e non ci sono errori di carricamento.

Ho trovato su internet anche altri che hanno problemi simili ai miei, ma mai una soluzione!

Grazie,
Miky


Offline RogoMantiK

  • Utente junior
  • **
  • Post: 61
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Xperia Neo
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #13 il: 08 Agosto 2012, 23:48:29 CEST »
0
io ho provato eclipse 4.2 sul linux ma non mi convinceva, troppo instabile e dava errori assurdi riguardo a cose deprecated (ad ogni avvio c'era qualcosa deprecated di nuovo pure gli onclick)
comunque adesso uso la 3.8 sempre su linux e mi trovo bene. della 4.2 non mi piace nemmeno la grafica nuova
ti consiglio di usarla tra qualche mese quando sarà ben testata e supportata da ADT eSDK
tu per sicurezza vai nella pagina internet da dove si scarica l'SDK di android e vedi la versione consigliata di eclipse tra i requisiti e scarica quella

Offline pamide

  • Nuovo arrivato
  • *
  • Post: 14
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    tablet HTC Flyer
  • Sistema operativo:
    Mac OS X 10.5
Re:Problemi installazione ambiente sviluppo Android - ADT per Eclipse
« Risposta #14 il: 09 Agosto 2012, 14:01:02 CEST »
0
Il problema e ADT non SDK. Ho installato la versione Indigo di Eclipse ma ADT si scarica da Eclipse. Non sò come fare a trovare una versione precedente e come installarla.

Grazie,
Miky