Autore Topic: app funzionante su emulatore e non su terminale  (Letto 796 volte)

Offline ilgrillo

  • Nuovo arrivato
  • *
  • Post: 2
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    HTC Magic
  • Sistema operativo:
    W 7 / W xp
app funzionante su emulatore e non su terminale
« il: 28 Giugno 2012, 23:27:32 CEST »
0
Ciao a tutti,
da lunedì finalmente sto sviluppando in maniera seria su android. La mia app effettua il login / registrazione su server online. Il mio problema è il seguente:

sull'emulatore l'app funziona tranquillamente, invece sul mio magic / S2 no. L'app va in crash una volta "cliccato" login o registrati.

Sapete illuminarmi?  :D

Offline gabric

  • Utente senior
  • ****
  • Post: 615
  • Respect: +18
    • Google+
    • Mostra profilo
    • Brancato's site
  • Dispositivo Android:
    Nexus 5 / Tablet mediacom s4
  • Play Store ID:
    Brancato's+app
  • Sistema operativo:
    window7. ubuntu
Re:app funzionante su emulatore e non su terminale
« Risposta #1 il: 28 Giugno 2012, 23:55:38 CEST »
0
Senza logcat è un pò difficile...
se non puoi collegare il dispositivo, scarica l'app alogcat
Qualche idea potrebbe essere, chiamate a file non caricati nel dispositivo, problema nel tipo di connessione (se magari il wifi è spento o simili)
altro non mi viene. il Logcat sicuramente ci sarà una mano

Offline ilgrillo

  • Nuovo arrivato
  • *
  • Post: 2
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    HTC Magic
  • Sistema operativo:
    W 7 / W xp
Re:app funzionante su emulatore e non su terminale
« Risposta #2 il: 29 Giugno 2012, 12:26:41 CEST »
0
Per prima cosa ti ringrazio per la risposta immediata fornita.

Il problema l'ho risolto riscrivendo il file Android manifest.xml .