Autore Topic: ACTIONBAR: metodo inestistente getActionBar()  (Letto 651 volte)

Offline esoni

  • Utente junior
  • **
  • Post: 102
  • Respect: 0
    • Mostra profilo
ACTIONBAR: metodo inestistente getActionBar()
« il: 25 Giugno 2012, 15:11:40 CEST »
0
ciao ragazzi ho un problema, il metodo getActionBar() non viene trovato e me lo da inesistente.
Codice (Java): [Seleziona]
//    private final void setStatus(int resId) {
//        final ActionBar actionBar = getActionBar();     <---ERRORE QUA COMPILATORE
//
//        actionBar.setSubtitle(resId);
//    }

//    private final void setStatus(CharSequence subTitle) {
//        final ActionBar actionBar = getActionBar();
//        actionBar.setSubtitle(subTitle);
//    }


COME CONsigliato in post che ho letto ho messo nel manifest
    <uses-sdk minSdkVersion="11" android:targetSdkVersion="11"/>
in modo che ci sia tale api... ma nulla non riesco a risolvere...

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +507
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:ACTIONBAR: metodo inestistente getActionBar()
« Risposta #1 il: 25 Giugno 2012, 16:54:54 CEST »
0
Dovresti controllare il build target del progetto (Progetto -> Proprietà -> Android).

Offline DarnellNajanReed

  • Utente normale
  • ***
  • Post: 359
  • Respect: +49
    • Google+
    • Mostra profilo
  • Dispositivo Android:
    LG Optimus One, Acer Iconia A500/501, Asus Transformer Prime, Galaxy ACE, Galaxy S Plus, Galaxy S Advance P, Galaxy Tab 2 7.0, Google Nexus 7
  • Play Store ID:
    Luigi Notaro
  • Sistema operativo:
    OS X 10.8.3
Re:ACTIONBAR: metodo inestistente getActionBar()
« Risposta #2 il: 25 Giugno 2012, 17:22:25 CEST »
0
Citazione
COME CONsigliato in post che ho letto ho messo nel manifest
    <uses-sdk minSdkVersion="11" android:targetSdkVersion="11"/>
in modo che ci sia tale api... ma nulla non riesco a risolvere...
In realtà nulla ti vieta di creare un progetto con questo manifest e SDK inferiore...hai controllato che il tuo progetto faccia riferimento effettivamente al giusto set di API (come suggerito da Ricky)?