Autore Topic: Aiuto urgente con la versione di un applicazione  (Letto 1102 volte)

Offline alex93

  • Utente junior
  • **
  • Post: 56
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung galaxy s2
  • Sistema operativo:
    Windows 8
Aiuto urgente con la versione di un applicazione
« il: 27 Maggio 2012, 16:47:16 CEST »
0
Ciao a tutti, ho un problema urgente che devo risolvere assolutamente.
Allora io ho creato un applicazione con android 4.0.3 e non ho pensato che molti telefoni non lo hanno ancora, quindi qualcuno saprebbe dirmi come riportare il progetto alla versione 2.2 o fare qualcosa per rendere l'applicazione leggibile anche a versioni precedenti!!Al momento so solo che l'APi serve a qualcosa,qualcuno mi spega bene!!
grazie mille in anticipo!!

Offline teskio

  • Moderatore globale
  • Utente normale
  • *****
  • Post: 387
  • Respect: +118
    • Github
    • Google+
    • Mostra profilo
    • Skullab
  • Dispositivo Android:
    Cubot GT99 / SurfTab Ventos 10.1
  • Play Store ID:
    Skullab Software
  • Sistema operativo:
    windows 7 / ubuntu 12.04
Re:Aiuto urgente con la versione di un applicazione
« Risposta #1 il: 27 Maggio 2012, 17:23:12 CEST »
0
http://it.wikipedia.org/wiki/Application_programming_interface
Platform Versions | Android Developers

Se vuoi un app compatibile per android 2.2 puoi usare fino alle API level 8
Per cambiare le API nel progetto, in eclipse :  Project -> Properties -> Android
« Ultima modifica: 27 Maggio 2012, 17:27:24 CEST da teskio »

Offline alex93

  • Utente junior
  • **
  • Post: 56
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung galaxy s2
  • Sistema operativo:
    Windows 8
Re:Aiuto urgente con la versione di un applicazione
« Risposta #2 il: 27 Maggio 2012, 21:35:25 CEST »
0
In questo modo renderei compatibile la mia applicazione fatta in 4.0.3 sensa rifarla da capo???
« Ultima modifica: 27 Maggio 2012, 21:37:11 CEST da alex93 »

Offline alex93

  • Utente junior
  • **
  • Post: 56
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung galaxy s2
  • Sistema operativo:
    Windows 8
Re:Aiuto urgente con la versione di un applicazione
« Risposta #3 il: 27 Maggio 2012, 21:45:12 CEST »
0
Pero mi sorge un dubbio,molti comandi usati nella versione 4.0.3 non funzioneranno nella 2.2, ad esempio il metodo isEmpty() delle edittext!! Sai qual è un metodo alternativo per controllare se una editText è vuota??

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Aiuto urgente con la versione di un applicazione
« Risposta #4 il: 27 Maggio 2012, 22:00:49 CEST »
0
Pero mi sorge un dubbio,molti comandi usati nella versione 4.0.3 non funzioneranno nella 2.2, ad esempio il metodo isEmpty() delle edittext!! Sai qual è un metodo alternativo per controllare se una editText è vuota??

Mistero!

Codice (Java): [Seleziona]
if(laTuaEditText.getText().toString().trim().lenght() > 0){
//Non è vuota
}

Offline alex93

  • Utente junior
  • **
  • Post: 56
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung galaxy s2
  • Sistema operativo:
    Windows 8
Re:Aiuto urgente con la versione di un applicazione
« Risposta #5 il: 27 Maggio 2012, 22:51:42 CEST »
0
grazie ho risolto tutto con un ignoraCase("")=true