Autore Topic: Emulatore che non fa partire il progetto  (Letto 732 volte)

Offline ignaz

  • Utente junior
  • **
  • Post: 54
  • Respect: +2
    • Mostra profilo
  • Dispositivo Android:
    Galaxy s2
  • Sistema operativo:
    Win 7 64bit
Emulatore che non fa partire il progetto
« il: 18 Maggio 2012, 09:56:44 CEST »
0
Qualcuno mi può aiutare ha sempre funzionato fino a ieri poi non riesco più a eseguire il debug
La console mi da che è tutto ok come sotto ma l'activity non parte!!

eclipse.buildId=M20120208-0800
java.version=1.6.0_31
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=it_IT
Command-line arguments:  -os win32 -ws win32 -arch x86 -data C:\Users\bolognini\Google Drive\Progetti\Android


[2012-05-18 09:49:00 - CvaWidgets] Android Launch!
[2012-05-18 09:49:00 - CvaWidgets] adb is running normally.
[2012-05-18 09:49:00 - CvaWidgets] Performing it.bolognini.CVA.ViewPagerFragmentActivity activity launch
[2012-05-18 09:49:08 - CvaWidgets] Uploading CvaWidgets.apk onto device 'emulator-5554'
[2012-05-18 09:49:12 - CvaWidgets] Installing CvaWidgets.apk...
[2012-05-18 09:49:44 - CvaWidgets] Success!
[2012-05-18 09:49:44 - CvaWidgets] Starting activity it.bolognini.CVA.ViewPagerFragmentActivity on device emulator-5554

Poi trovo nell'Erro Log questa eccezione:
Error
Fri May 18 09:54:27 CEST 2012
No command output when running: 'am start -D -n it.test.TestActivity -a android.intent.action.MAIN -c android.intent.category.LAUNCHER' on device emulator-5554

com.android.ddmlib.ShellCommandUnresponsiveException
   at com.android.ddmlib.AdbHelper.executeRemoteCommand(AdbHelper.java:408)
   at com.android.ddmlib.Device.executeShellCommand(Device.java:388)
   at com.android.ide.eclipse.adt.internal.launch.ActivityLaunchAction.doLaunchAction(ActivityLaunchAction.java:75)
   at com.android.ide.eclipse.adt.internal.launch.AndroidLaunchController.launchApp(AndroidLaunchController.java:1201)
   at com.android.ide.eclipse.adt.internal.launch.AndroidLaunchController.simpleLaunch(AndroidLaunchController.java:877)
   at com.android.ide.eclipse.adt.internal.launch.AndroidLaunchController.access$4(AndroidLaunchController.java:861)
   at com.android.ide.eclipse.adt.internal.launch.AndroidLaunchController$3.run(AndroidLaunchController.java:709)



jfrankie

  • Visitatore
Re:Emulatore che non fa partire il progetto
« Risposta #1 il: 18 Maggio 2012, 12:44:36 CEST »
0
Prova a fare un clean del simulatore.
Se usi eclipse quando esegui il tuo apk (RunAs) poi vai Run configuration selezioni il tab Target e poi Wipe User data.

Offline ignaz

  • Utente junior
  • **
  • Post: 54
  • Respect: +2
    • Mostra profilo
  • Dispositivo Android:
    Galaxy s2
  • Sistema operativo:
    Win 7 64bit
R: Emulatore che non fa partire il progetto
« Risposta #2 il: 18 Maggio 2012, 13:50:05 CEST »
0
Già provato ma continua a non andare, ho visto che anche altri hanno avuto lo stesso problema ma non ho trovato risposta

Inviato dal mio Transformer TF101 usando Tapatalk