Autore Topic: Eclipse Indigo  (Letto 1085 volte)

Offline Defkon1

  • Nuovo arrivato
  • *
  • Post: 10
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Ubuntu
Eclipse Indigo
« il: 15 Maggio 2012, 12:05:55 CEST »
0
sto preparando una nuova macchina da sviluppo (kubuntu 12.04), ma eclipse non vuole saperne di vedermi l'ambiente android...

premesso che su altre macchine ho installato tutto con successo (ma diverso tempo fa), riepilogo i passi che ho fatto (magari sto saltando qualche inezia, che inezia non è):

 - scaricato sdk rev18 e scompattato in ~/android-sdk-linux
 - aggiunto a .bashrc il path ai tools e ai platform-tools
 - installato eclipse da apt-get
 - aggiunto il repo dell'adt in eclipse
 - installato adt da eclipse
 - riavviato la macchina

a questo punto mi aspettavo di vedere nelle preferenze di eclipse la possibilità di configurare il percorso all'sdk, e di lanciare il manager dei pacchetti e degli avd, ma non è comparsa nessuna nuova voce.

sono quindi entrato in ~/android-sdk-linux/tools e lanciato android, da cui ho potuto scaricare i vari pacchetti e anche creare un avd di test senza problemi...

eclipse però continua a non farmi vedere nulla relativo ad android, né tra le preferenze, né quando vado su Nuovo...

cosa sto sbagliando?

grazie in anticipo

Offline Defkon1

  • Nuovo arrivato
  • *
  • Post: 10
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Ubuntu
Re:Eclipse Indigo
« Risposta #1 il: 15 Maggio 2012, 16:23:53 CEST »
0
sono riuscito a risolvere:

- ho disinstallato l'adt
- lanciato un sudo eclipse -clean
- installato da superuser l'adt
- lanciato eclipse -clean

da quello che ho letto in giro sono in diversi ad avere questo problema di "permessi" su una fresh installation di indigo (e non solo su linux)...

spero che questo post risparmi a qualcuno le ore che c'ho passato io...  :-P

Offline iceweasel

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 878
  • Respect: +147
    • Mostra profilo
  • Dispositivo Android:
    LGE P990 - Google Nexus 5
  • Sistema operativo:
    Linux Debian Sid
Re:Eclipse Indigo
« Risposta #2 il: 15 Maggio 2012, 16:49:59 CEST »
0
Eclipse se installato da un repository di una distribuzione viene installato con l'utente root. Se un utente normale vuole installare un plugin, installer del plugin modifica alcuni file di Eclipse ma questo non è possibile visto che gli utenti sono diversi, quindi l'installazione fallisce.

Stanno lavorando per risolvere questo problema ma non è detto che la versione di Eclipse presente nella distribuzione sia corretta.

Sconsiglio di installare un plugin di Eclipse da root, questioni di sicurezza. Consiglio di disistallare Eclipse e di installarlo localmente scaricandolo dal sito ufficiale e poi installare con l'utente normale i plugin richiesti.
adb logcat | tee /tmp/logcat | grep TAG

Offline Defkon1

  • Nuovo arrivato
  • *
  • Post: 10
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Ubuntu
Re:Eclipse Indigo
« Risposta #3 il: 15 Maggio 2012, 17:04:59 CEST »
0
Consiglio di disistallare Eclipse e di installarlo localmente scaricandolo dal sito ufficiale e poi installare con l'utente normale i plugin richiesti.

ok, thanks!

questa è una macchina di test secondaria e ormai la lascio così, ma mi tengo buono il consiglio per la prossima macchina sviluppo!  :-)