Autore Topic: Activity genera errore!  (Letto 597 volte)

Offline Smoke666

  • Nuovo arrivato
  • *
  • Post: 24
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Ubuntu 11.04, Windows 7
Activity genera errore!
« il: 03 Maggio 2012, 15:23:48 CEST »
0
Ciao a tutti, stavo eseguendo la mia app, ma solo uno dei 6 pulsanti presenti funziona correttamente, gli altri generano tutti il medesimo errore. Posto il log relativo ad uno solo:

Codice: [Seleziona]
05-03 13:14:57.683: E/AndroidRuntime(317):         at android.app.Instrumentation.checkStartActivityResult(Instrumentation.java:1404)
05-03 13:14:57.683: E/AndroidRuntime(317):         at android.app.Instrumentation.execStartActivity(Instrumentation.java:1378)
05-03 13:14:57.683: E/AndroidRuntime(317):         at android.app.Activity.startActivityForResult(Activity.java:2817)
05-03 13:14:57.683: E/AndroidRuntime(317):         at android.app.Activity.startActivity(Activity.java:2923)
05-03 13:14:57.683: E/AndroidRuntime(317):         at francesco.lucente.selezionaProdotti$2.onClick(selezionaProdotti.java:37)
05-03 13:14:57.683: E/AndroidRuntime(317):         at android.view.View.performClick(View.java:2408)
05-03 13:14:57.683: E/AndroidRuntime(317):         at android.view.View$PerformClick.run(View.java:8816)
05-03 13:14:57.683: E/AndroidRuntime(317):         at android.os.Handler.handleCallback(Handler.java:587)
05-03 13:14:57.683: E/AndroidRuntime(317):         at android.os.Handler.dispatchMessage(Handler.java:92)
05-03 13:14:57.683: E/AndroidRuntime(317):         at android.os.Looper.loop(Looper.java:123)
05-03 13:14:57.683: E/AndroidRuntime(317):         at android.app.ActivityThread.main(ActivityThread.java:4627)
05-03 13:14:57.683: E/AndroidRuntime(317):         at java.lang.reflect.Method.invokeNative(Native Method)
05-03 13:14:57.683: E/AndroidRuntime(317):         at java.lang.reflect.Method.invoke(Method.java:521)
05-03 13:14:57.683: E/AndroidRuntime(317):         at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:868)
05-03 13:14:57.683: E/AndroidRuntime(317):         at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
05-03 13:14:57.683: E/AndroidRuntime(317):         at dalvik.system.NativeStart.main(Native Method)

Da qui si intuisce che non è dichiarata la classe nel Manifest, ma non è così, posto anche la dichiarazione, magari c'è un errore li...

Codice (XML): [Seleziona]
       
         <activity
           android:name=".rosticceria"
           android:label="@string/app_name" >
            <intent-filter>
                <action android:name="android.intent.action.ROSTICCERIA" />
                <category android:name="android.intent.category.LAUNCHER" />
            </intent-filter>            
        </activity>

L'intent è così invocata:

Codice (Java): [Seleziona]
   
 bRosticceria.setOnClickListener(new OnClickListener(){      
                public void onClick(View v) {
                        // TODO Auto-generated method stub
                        Intent rosticceriaIntent = new Intent(selezionaProdotti.this, rosticceria.class);
                        startActivity(rosticceriaIntent);
                }

});
   


Cosa potrebbe essere? Grazie in anticipo!
« Ultima modifica: 03 Maggio 2012, 15:29:54 CEST da Smoke666 »

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +507
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Activity genera errore!
« Risposta #1 il: 03 Maggio 2012, 15:32:32 CEST »
0
Cosa sarebbe <action android:name="android.intent.action.ROSTICCERIA" /> ?
 

Offline Smoke666

  • Nuovo arrivato
  • *
  • Post: 24
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Ubuntu 11.04, Windows 7
Re:Activity genera errore!
« Risposta #2 il: 03 Maggio 2012, 15:41:21 CEST »
0
E' l'action dell'activity da lanciare, cosa c'è di sbagliato?  :-o

Offline Smoke666

  • Nuovo arrivato
  • *
  • Post: 24
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Ubuntu 11.04, Windows 7
Re:Activity genera errore!
« Risposta #3 il: 03 Maggio 2012, 15:53:56 CEST »
0
Chiedo scusa, avevo messo il tag     </application> nel posto sbagliato !  O:-)