Autore Topic: Strano problema con gallery  (Letto 787 volte)

Offline linoma

  • Nuovo arrivato
  • *
  • Post: 22
  • Respect: 0
    • Mostra profilo
Strano problema con gallery
« il: 24 Aprile 2012, 15:05:46 CEST »
0
Salve,

ho un picoclo problema con gallery, ovvero carico le immagini, me le visualizza ma mi mostra uno spazio bianco a sinistra. Sbaglio qualcosa? Allego uno screenshot


Grazie per le risposte.

Offline verzothedrummer

  • Nuovo arrivato
  • *
  • Post: 1
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Acer Iconia Tab A501
  • Sistema operativo:
    Win Xp, Win 7, Ubuntu 11.10
Re:Strano problema con gallery
« Risposta #1 il: 14 Maggio 2012, 09:49:51 CEST »
0
Ciao Linoma, anche io ho lo stesso "problema" che penso sia dovuto al fatto che la galleria di immagini copra tutta la riga (immagino che tu abbia usato un linear layout?) e che la prima immagine dell'array venga caricata nella posizione centrale che è quella evidenziata.
In questo modo, è come se la prima immagine fosse posta al centro dello schermo, le altre in sequenza alla sua destra mentre a sx rimane lo spazio vuoto.
L'ho notato perchè poi scorrendo le immagini lo spazio si riempie con quelle già scorse, almeno per la mia versione.
purtroppo non saprei come ovviare al problema che però, a mio parere, nel mio programma è trascurabile.

Offline linoma

  • Nuovo arrivato
  • *
  • Post: 22
  • Respect: 0
    • Mostra profilo
Re:Strano problema con gallery
« Risposta #2 il: 15 Maggio 2012, 13:51:10 CEST »
0
Si è trascurabile. Forse non è neanche un difetto sarà fatto di proposito dal controllo per un fattore estetico. Cmq pensavo ci fosse qualche proprietà che potesse in qualche modo farlo sparire. Grazie cmq x la risposta :)