Autore Topic: Problema con "import"  (Letto 838 volte)

Offline Sebastian

  • Utente junior
  • **
  • Post: 81
  • Respect: 0
    • Mostra profilo
Problema con "import"
« il: 10 Agosto 2010, 17:08:21 CEST »
0
Salve a tutti,
programmando un applicazione android in eclipse se scrivo:

-"import android.content.IntentReceiver;"
il programma mi dice: "The import android.content.IntentReceiver cannot be resolved"

mentre se scrivo:
-"import android.telephony.gsm.SmsMessage;"
il programma mi dice: "The type SmsMessage is deprecated"

e lo fa anche con altri import... sapete per caso che significa e come si può rimediare?

Mille grazie
« Ultima modifica: 10 Agosto 2010, 18:07:51 CEST da Sebastian »

Offline MarcoDuff

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 1073
  • Respect: +202
    • Google+
    • marcoduff
    • Mostra profilo
    • MarcoDuff's Blog
  • Dispositivo Android:
    Samsung Galaxy Nexus
  • Play Store ID:
    MarcoDuff
  • Sistema operativo:
    Windows 7
Re:Problema con "import"
« Risposta #1 il: 17 Agosto 2010, 09:51:46 CEST »
0
-"import android.content.IntentReceiver;"
il programma mi dice: "The import android.content.IntentReceiver cannot be resolved"

La classe IntentReceiver non esiste, ecco perché ti dice che non riesce ad importarla.
Cosa volevi fare?

-"import android.telephony.gsm.SmsMessage;"
il programma mi dice: "The type SmsMessage is deprecated"

Quella classe è deprecata (ovvero resa obsoleta dagli sviluppatori di android) e non dovrebbe più essere utilizzata. Al suo posto utilizza la classe android.telephony.SmsMessage

Ciao!

Offline Sebastian

  • Utente junior
  • **
  • Post: 81
  • Respect: 0
    • Mostra profilo
Re:Problema con "import"
« Risposta #2 il: 17 Agosto 2010, 14:42:27 CEST »
0
mille grazie!