Autore Topic: Problemi compatibilità AdMob  (Letto 845 volte)

Offline cdr89

  • Nuovo arrivato
  • *
  • Post: 15
  • Respect: 0
    • Mostra profilo
Problemi compatibilità AdMob
« il: 11 Marzo 2012, 23:08:33 CET »
0
Ciao a tutti!
Qualcuno sa dirmi come posso far funzionare AdMob anche su dispositivi con versione Android minore di 3.2?
L'applicazione sul mio (2.3) funziona alla perfezione ma quando la metto nel market e provo a scaricarla dallo stesso dispositivo non riesco a scaricarla...

Note:
1) nel file project.properties ho settato target=android-13 (necessario a far funzionare AdMob);
2) nel manifest ho settato minSdkVersion="3" (per ampliare al max la compatibilità);

Offline blackgin

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 1387
  • Respect: +164
    • Google+
    • blackgins
    • blackginsoft
    • Mostra profilo
  • Dispositivo Android:
    Galaxy Nexus
  • Sistema operativo:
    Mac OSX 10.8
Re:Problemi compatibilità AdMob
« Risposta #1 il: 12 Marzo 2012, 13:21:30 CET »
0
Ciao a tutti!
Qualcuno sa dirmi come posso far funzionare AdMob anche su dispositivi con versione Android minore di 3.2?
L'applicazione sul mio (2.3) funziona alla perfezione ma quando la metto nel market e provo a scaricarla dallo stesso dispositivo non riesco a scaricarla...

Note:
1) nel file project.properties ho settato target=android-13 (necessario a far funzionare AdMob);
2) nel manifest ho settato minSdkVersion="3" (per ampliare al max la compatibilità);
Non riesci a scaricarla nel senso che non la vedi o nel senso che ti da errore?
Postate il LogCat LogCat LogCat LogCat LogCat

Offline cdr89

  • Nuovo arrivato
  • *
  • Post: 15
  • Respect: 0
    • Mostra profilo
Re:Problemi compatibilità AdMob
« Risposta #2 il: 12 Marzo 2012, 13:59:22 CET »
0
La vedo ma sono impossibilitato nello scaricarla perchè secondo il market non è compatibile con il mio dispositivo

Offline eagledeveloper

  • Translate Team
  • Utente senior
  • ****
  • Post: 516
  • Respect: +37
    • Google+
    • 347516210
    • dark_pinz
    • @WandDStudios
    • Mostra profilo
    • W&D Studios
  • Dispositivo Android:
    HTC One X e HTC One
  • Play Store ID:
    W%26D+Studios
  • Sistema operativo:
    Ubuntu / Windows 7
Re:Problemi compatibilità AdMob
« Risposta #3 il: 12 Marzo 2012, 14:28:08 CET »
0
Io nel mio manifest ho messo questo:

Codice (XML): [Seleziona]
<uses-sdk
       android:minSdkVersion="8"
       android:targetSdkVersion="13" />

Se non fosse compatibile per il tuo dispositivo il market se non sbaglio non te la farebbe nemmeno vedere. Ci dev'essere qualcosa d'altro che non va. Il project.properties è corretto.
Prova a darci ulteriori dettagli, messaggi d'errore o cosa succede esattamente.

Saluti.
I numeri contano molto di più del seme.

Offline cdr89

  • Nuovo arrivato
  • *
  • Post: 15
  • Respect: 0
    • Mostra profilo
Re:Problemi compatibilità AdMob
« Risposta #4 il: 12 Marzo 2012, 14:51:25 CET »
0
Quello che posso aggiungere è che ho dovuto mettere due apk e farli coesistere nel market (su quello senza pubblicità ho dovuto mettere delle limitazioni).

La versione vecchia dell'app ha i seguenti metadati e funziona correttamente sul mio dispositivo:
Codice versione: 2
Nome versione: 1.0.1
Livello API: 8-16+

L'altra versione, ha questi altri metadati:
Codice versione: 6
Nome versione: 1.1.3
Livello API: 3-16+

Quindi in teoria la seconda dovrebbe essere compatibile con più dispositivi rispetto la seconda... ma se provo a togliere la versione 2 google mi segnala che i dispositivi compatibili dopo la modifica saranno di meno!!!
Quando effettuo il download con il mio dispositivo (v 2.3) l'app scaricata è la versione 1.0.1 (senza pubblicità).
Accetto anche proposte su altri sistemi di advertising se ne avete avuto buone esperienze.

Offline eagledeveloper

  • Translate Team
  • Utente senior
  • ****
  • Post: 516
  • Respect: +37
    • Google+
    • 347516210
    • dark_pinz
    • @WandDStudios
    • Mostra profilo
    • W&D Studios
  • Dispositivo Android:
    HTC One X e HTC One
  • Play Store ID:
    W%26D+Studios
  • Sistema operativo:
    Ubuntu / Windows 7
Re:Problemi compatibilità AdMob
« Risposta #5 il: 12 Marzo 2012, 16:50:13 CET »
0
Coesistere? Cosa intendi? Il package name dev'essere unico. Se vuoi mettere due applicazioni, una free con la pubblicita' e l'altra senza pubblicita' devi usare due package name diversi, tipo: x.x.x.free e x.x.x.pro o qualcosa di simile.
I dispositivi compatibili dipendo anche dalla permissions nel manifest e da altri attributi.
I tuoi manifest sono uguali oppure no?
AdMob e' un buon inizio ha pubblicita' in tutto il mondo ed e' semplice da utilizzare.
I numeri contano molto di più del seme.

Offline cdr89

  • Nuovo arrivato
  • *
  • Post: 15
  • Respect: 0
    • Mostra profilo
Re:Problemi compatibilità AdMob
« Risposta #6 il: 13 Marzo 2012, 12:39:47 CET »
0
E' possibile invece utilizzando lo stesso package name e versioni di dispositivi diverse. Ovviamente le due versioni sono entrambe free (soltanto che una con meno limitazioni ha la pubblicità e viene scaricata dai dispositivi 3.2+ e l'altra con più limitazioni è scaricata da dispositivi con versione <3.2).
I manifest sono uguali, cambia solo il project.properties (per necessità di utilizzare AdMob)

Offline eagledeveloper

  • Translate Team
  • Utente senior
  • ****
  • Post: 516
  • Respect: +37
    • Google+
    • 347516210
    • dark_pinz
    • @WandDStudios
    • Mostra profilo
    • W&D Studios
  • Dispositivo Android:
    HTC One X e HTC One
  • Play Store ID:
    W%26D+Studios
  • Sistema operativo:
    Ubuntu / Windows 7
Re:Problemi compatibilità AdMob
« Risposta #7 il: 13 Marzo 2012, 13:49:47 CET »
0
Non riesco a capire.
Comunque il mio consiglio é fare due applicazioni distinte.
È una soluzione pulita, così da all'utente la scelta di quale applicazione scaricare, se gli piace quella "lite" si scarica la "pro".
Le pubblicità girano tranquillamente anche su device "inferiori" come 2.2 e 2.3.

Che ne dici?
I numeri contano molto di più del seme.

Offline cdr89

  • Nuovo arrivato
  • *
  • Post: 15
  • Respect: 0
    • Mostra profilo
Re:Problemi compatibilità AdMob
« Risposta #8 il: 13 Marzo 2012, 14:48:49 CET »
0
Ho già anche la versione "pro" a pagamento, ho dovuto inserire 2 versioni gratuite perchè la versione con la pubblicità era ristretta solo ad alcuni utenti...

Offline eagledeveloper

  • Translate Team
  • Utente senior
  • ****
  • Post: 516
  • Respect: +37
    • Google+
    • 347516210
    • dark_pinz
    • @WandDStudios
    • Mostra profilo
    • W&D Studios
  • Dispositivo Android:
    HTC One X e HTC One
  • Play Store ID:
    W%26D+Studios
  • Sistema operativo:
    Ubuntu / Windows 7
Re:Problemi compatibilità AdMob
« Risposta #9 il: 13 Marzo 2012, 16:00:13 CET »
0
The Google AdMob Ads SDK for Android requires Android 1.5 or later.

Non ti bruci nessun utente ;)

Saluti.
I numeri contano molto di più del seme.