Autore Topic: Richiesta Sos su versione minSdkVersion  (Letto 386 volte)

Offline enfandroid

  • Nuovo arrivato
  • *
  • Post: 35
  • Respect: 0
    • Mostra profilo
  • Play Store ID:
    enfandroid
Richiesta Sos su versione minSdkVersion
« il: 19 Gennaio 2012, 16:05:16 CET »
0
Ciao a tutti sono enfandroid novello programmatore per android grazie ad app inventor . In pochi mesi grazie a questo strumento ho messo su due applicazioni abbastanza interessanti, di cui una secondo me molto utile per gli stessi sviluppatori di app , ma non sono qui per farmi pubblicità....
Voglio porre un quesito credo molto complicato:
ho pubblicato la mia ultima app sviluppato con app inventor e compilata secondo i tutorial del gran benefattore Seblog Android Apps .
Inizialmente modifico il manifest inserendo minSdkVersion="3" perchè penso da questa versione in poi tutti dovrebbero riusce a leggere l'app e la pubblico .
Ora lo stesso file che ho pubblicato lo mando via email a mio fratello che ha un Samsung gt-s5570 per fargliela testare. Lui la scarica e la visualizza correttamente , mentre sul market il suo cell non la vede , infatti collegandomi sul market da un pc con il suo account mi dice che non è compatibile con quel modello di dispositivo . Allora modifico il manifest minSdkVersion="7" e lo ripubblico e mi da un numero di dispositivi compatibili con la mia app piu elevato e anche mio fratello vede l'app dal suo dispositivo come compatibile. Sul samsung di mio fratello la versione di android è la 2.2 .
C'è un problema però, l'app che ho mandato a mio fratello via email con minSdkVersion="3" e che è riuscito a installare tranquillamente , viene visualizzata correttamente cioè nell'app ci sono dei pulsanti che sono visualizzati come nell'immagine allegata, invece quando avvia l'app scaricata dal market con minSdkVersion="7" i pulsanti sono piu larghi e arriva a visualizzare fino al pulsante blue e l'ultimo pulsante va verso destra e deve ruotare il dispositivo per poterlo vedere (anche un logo iniziale che metto come splash di avvio viene piu grande) . Io invece ho un cell. cinese con android 2.1 una sottomarca e l'app viene vista bene in qualsiasi modo.

C'è qualcuno che puo darmi una spiegazione, inoltre come mai un app con manifest minSdkVersion="3" vede meno dispositivi di un app con manifest minSdkVersion="7" ?


Grazie a tutti per la disponibilità....
« Ultima modifica: 19 Gennaio 2012, 16:06:57 CET da enfandroid »