Autore Topic: Problema visualizzazione contenuto webView  (Letto 774 volte)

Offline ale88sv

  • Nuovo arrivato
  • *
  • Post: 41
  • Respect: +1
    • Google+
    • Mostra profilo
    • Le Mie Apps
  • Dispositivo Android:
    Galaxy Nexus
  • Play Store ID:
    ale88sv
  • Sistema operativo:
    Windows 7 / Ubuntu 12.4
Problema visualizzazione contenuto webView
« il: 22 Novembre 2011, 16:01:11 CET »
0
Ciao a tutti non so se sono proprio nella sezione giusta ... nel caso mi scuso ..

Veniamo al problema..
Devo inserire dei contenuti html in una webview , il 90% dei contenuti si visualizza il restante no, il problema è che non capisco il perchè |!!!
esempio

Contenuto OK
Codice (XML): [Seleziona]
<div class="content">
</br><a href="http://vimeo.com/28365485"> [url=http://vimeo.com/28365485]Nike Vapen Sessions Episode 1 on Vimeo[/url] </a> </br><br />
Mamma mia che sogno... quanto mi piacerebbe girare in un posto cos&igrave;
 (mi basta un saltino da tre metri,ma con uno sfondo cos&igrave;...)
 <img src="http://www.snowboard-italia.com/forum/images/smilies/sbav.gif" alt=":sbav:" title="sbav" />
</div>                                                  <div class="notice">Ultima modifica di
<a href="http://www.snowboard-italia.com/forum/memberlist.php?mode=viewprofile&amp;u=349&amp;sid=457742cdc1a90aba469368415bfadcb1"
style="color: #009900;" class="username-coloured">Gnagno</a> il lun nov 14, 2011 12:59 am, modificato 1
 volta in totale.                                       <br /><strong>Motivazione:</strong>
<em>x postare direttamente il player inserisci tra i 2 tag solamente il codice che si trova dopo la / ,per esempio in questo caso era 28365485 ;)</em>                          </div> 

Contenuto KO
Codice (XML): [Seleziona]
 <div class="content">Antiout - (Free) - Anti Autti e riders finnici in powder 100%<br />
</br><a href="http://vimeo.com/31451680"> [url=http://vimeo.com/31451680]ANTIOUT on Vimeo[/url] </a> </br>
<br /><br />Volendo &egrave; scaricabile da qui: <img src="http://www.snowboard-italia.com/forum/images/smilies/icon_censored.gif"
alt=":censura:" title="" />  
<img src="http://www.snowboard-italia.com/forum/images/smilies/icon_rolleyes.gif" alt=":roll:" title="Rolling Eyes" />  
<img src="http://www.snowboard-italia.com/forum/images/smilies/bisbiglio.gif" alt=":pss:" title="psss" />
... tipo, ehm, il paese dei video-balocchi...</div>                                                     <div class="notice">Ultima modifica di <a href="http://www.snowboard-italia.com/forum/memberlist.php?mode=viewprofile&amp;u=349&amp;sid=457742cdc1a90aba469368415bfadcb1" style="color: #009900;"
 class="username-coloured">Gnagno</a> il lun nov 14, 2011 1:01 am, modificato 1 volta in totale.                       
                <br /><strong>Motivazione:</strong> <em>x postare direttamente il player inserisci tra i 2 tag
 solamente il codice che si trova dopo la / ,per esempio in questo caso era 31451680 ;)</em>                   
        </div> 

scusate se è indentato con il c....

non riesco a venirne a capo ...

quando non me lo visualizza mi da questo :



la pagina la carico cosi :
Codice (Java): [Seleziona]
                holder.user_post.loadData(_postList.get(position).getPost(),"text/html", "UTF-8");
                holder.user_post.getSettings().setJavaScriptEnabled(true);
                // apro il link con il browser
                holder.user_post.setWebViewClient(new WebViewClient(){
                    public boolean shouldOverrideUrlLoading(WebView view, String url) {
                        if (url != null && url.startsWith("http://")) {
                            view.getContext().startActivity(
                                new Intent(Intent.ACTION_VIEW, Uri.parse(url)));
                            return true;
                        } else {
                            return false;
                        }
                    }
                });



Grazie in anticipo ;)

Ale

Offline ale88sv

  • Nuovo arrivato
  • *
  • Post: 41
  • Respect: +1
    • Google+
    • Mostra profilo
    • Le Mie Apps
  • Dispositivo Android:
    Galaxy Nexus
  • Play Store ID:
    ale88sv
  • Sistema operativo:
    Windows 7 / Ubuntu 12.4
Re:Problema visualizzazione contenuto webView
« Risposta #1 il: 28 Novembre 2011, 15:20:14 CET »
0
Mi metto un +1 da solo xD

era colpa del carattere %

no comment xD