Autore Topic: Non mi trovo l'immagine in R.id....  (Letto 422 volte)

Offline ippofil

  • Nuovo arrivato
  • *
  • Post: 13
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galax S
  • Sistema operativo:
    Windows 7
Non mi trovo l'immagine in R.id....
« il: 03 Novembre 2011, 12:43:50 CET »
0
Salve come devo caricare le mie foto in modo tale da ritrovarle in R.id e poterle così utilizzare??

Io ho provato a caricarle in /res/drawable-hdpi ma poi non me le ritrovo nella classe R.id. c'è una procedura particolare nel caricare??

Grazie
Quando un utente fornisce una risposta utile si può ringraziarlo premendo il tasto http://www.anddev.it/Themes/default/images/gpbp_2_arrow_up_lit.png   alla destra del titolo del post.

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +507
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Non mi trovo l'immagine in R.id....
« Risposta #1 il: 03 Novembre 2011, 12:56:19 CET »
0
Il riferimento lo ottieni con R.drawable non R.id

Offline ippofil

  • Nuovo arrivato
  • *
  • Post: 13
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galax S
  • Sistema operativo:
    Windows 7
Re:Non mi trovo l'immagine in R.id....
« Risposta #2 il: 03 Novembre 2011, 13:04:50 CET »
0
Vero avevo scritto male, ma il mio problema è che non mi trovo le nuove immagini in R
Codice (Java): [Seleziona]
public final class R {
    public static final class attr {
    }
    public static final class drawable {
        public static final int icon=0x7f020000;
    }
    public static final class id {
        public static final int buttonIndietro=0x7f050016;
        public static final int buttonInviaRichiesta=0x7f050004;
        public static final int buttonSalva=0x7f050011;
        public static final int spinnerModello=0x7f050002;
        public static final int textView1=0x7f050000;
    }
    public static final class layout {
        public static final int main=0x7f030000;
    }
    public static final class string {
        public static final int ColoreEsterno=0x7f040006;
        public static final int anno=0x7f040003;
        public static final int app_name=0x7f04000b;
        public static final int carburante=0x7f040005;
        public static final int carrozzeria=0x7f040000;
    }
}
ma solo l'icona di deufolt!!!!
Quando un utente fornisce una risposta utile si può ringraziarlo premendo il tasto http://www.anddev.it/Themes/default/images/gpbp_2_arrow_up_lit.png   alla destra del titolo del post.

Offline ippofil

  • Nuovo arrivato
  • *
  • Post: 13
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galax S
  • Sistema operativo:
    Windows 7
Re:Non mi trovo l'immagine in R.id....
« Risposta #3 il: 03 Novembre 2011, 16:07:13 CET »
0
Risolto  :-) caricavo un file che conteneva una letterea MAIUSCOLA e non gli va bene!!!

es.
FileAuto.png    Non va bene
file_auto.png     Ok
Quando un utente fornisce una risposta utile si può ringraziarlo premendo il tasto http://www.anddev.it/Themes/default/images/gpbp_2_arrow_up_lit.png   alla destra del titolo del post.