Autore Topic: Emulatore Vuoto  (Letto 909 volte)

Offline DevMobile

  • Nuovo arrivato
  • *
  • Post: 2
  • Respect: 0
    • Mostra profilo
Emulatore Vuoto
« il: 27 Ottobre 2011, 10:38:21 CEST »
0
Ciao a tutti!!

mi sto avvicinando al mondo ANDROID e volevo cominciare con le cose più semplici, installare l'ambiente ed eseguire il famoso "Hello World".

Ieri mi sono scaricato / installato / e configurato tutto, penso correttamente, ma quando vado ad eseguire il tutto sull'emulatore, parte e ma la finestra rimane vuota , rimane al centro solo la scritta android e non viene visualizzato nessuna scritta.
Ho provato ad inserire altre text e altri oggetti, ma nulla, emulatore completamente nero e scritta centrale ANDROID.
Ho convigurato come Virtual Device la Versione Android 4.

Premetto che ho installato l'SDK Android con i valori di default, quindi ha installato tutto nella cartella di default.
Ho letto nel forum che uno dei problemi potrebbe essere dovuto all'installazione dell SDK nella cartella Program Files, ma prima di disinstallare e reinstallare tutto volevo sapere qualche parere dei più esperti.

SO. Windows Vista.

Grazie anticipatamente a chi saprà darmi una mano.


Offline blackgin

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 1387
  • Respect: +164
    • Google+
    • blackgins
    • blackginsoft
    • Mostra profilo
  • Dispositivo Android:
    Galaxy Nexus
  • Sistema operativo:
    Mac OSX 10.8
Re:Emulatore Vuoto
« Risposta #1 il: 27 Ottobre 2011, 10:43:18 CEST »
0
Beh, l'emulatore vuole un certo tempo per avviarsi.. Lo aspetti?
Postate il LogCat LogCat LogCat LogCat LogCat

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Emulatore Vuoto
« Risposta #2 il: 27 Ottobre 2011, 10:51:01 CEST »
0
Cruccio di tutti noi sviluppatori Android, è la lentezza cronica dell'emulatore, lentezza che cresce esponenzialmente con le dimensioni dello schermo e l'API level.

Poichè quindi, come hanno già detto, l'emulatore è lentissimo a partire, o aspetti un po' (anche 5 minuti su macchine molto lente) o fai una prova con un dispositivo con API molto bassa e schermi piccolissimo, per vedere se ti parte in un tempo ragionevole.

EDIT: Vale la pena scrivere anche il perchè della lentezza. Gli emulatori Android sono veri e propri emulatori del sistema reale, si tratta dell'immagine binaria di un Android vero e proprio, caricata in una macchina virtuale QEMU che emula il processore ARM. Ambienti di sviluppo di altre piattaforme non usano questo approccio e sono molto più veloci, ma meno rappresentativi.
« Ultima modifica: 27 Ottobre 2011, 10:53:37 CEST da bradipao »
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline DevMobile

  • Nuovo arrivato
  • *
  • Post: 2
  • Respect: 0
    • Mostra profilo
Re:Emulatore Vuoto [RISOLTO]
« Risposta #3 il: 27 Ottobre 2011, 11:11:08 CEST »
0
Grazie mille ragazzi !!

Per la celere risposta e sopratutto per le spiegazioni dettagliate sull'emulatore e sulla sua lentezza, aspettavo circa 5 minuti, ma non succedeva nulla, è bastato aspettarne 8 e tutto si è risolto è finalmente apparsa la scritta HELLO WORD !!


[2011-10-27 11:02:21 - HelloWorld] ------------------------------
[2011-10-27 11:02:21 - HelloWorld] Android Launch!
[2011-10-27 11:02:21 - HelloWorld] adb is running normally.
[2011-10-27 11:02:21 - HelloWorld] Performing ivan.android.HelloWorldActivity activity launch
[2011-10-27 11:02:21 - HelloWorld] Automatic Target Mode: launching new emulator with compatible AVD 'AndroidVD4'
[2011-10-27 11:02:21 - HelloWorld] Launching a new emulator with Virtual Device 'AndroidVD4'
[2011-10-27 11:02:30 - HelloWorld] New emulator found: emulator-5554
[2011-10-27 11:02:30 - HelloWorld] Waiting for HOME ('android.process.acore') to be launched...
[2011-10-27 11:04:31 - HelloWorld] HOME is up on device 'emulator-5554'
[2011-10-27 11:04:31 - HelloWorld] Uploading HelloWorld.apk onto device 'emulator-5554'
[2011-10-27 11:04:32 - HelloWorld] Installing HelloWorld.apk...
[2011-10-27 11:05:41 - HelloWorld] Success!
[2011-10-27 11:08:41 - HelloWorld] Starting activity ivan.android.HelloWorldActivity on device emulator-5554
[2011-10-27 11:08:44 - HelloWorld] ActivityManager: Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=ivan.android/.HelloWorldActivity }

Grazie mille!
Buona giornata !

Offline Luigi.Arena

  • Utente senior
  • ****
  • Post: 616
  • DACIA DUSTER 4X4 SUPER
  • Respect: +56
    • Mostra profilo
    • ArenaWebTest
  • Dispositivo Android:
    epad m009
  • Play Store ID:
    Luigi Arena
  • Sistema operativo:
    Windows 7
Re:Emulatore Vuoto
« Risposta #4 il: 27 Ottobre 2011, 15:15:40 CEST »
0
Mi ricordi le pmie prime volte :-) aspettavo e non succedeva nulla... allora fermavo tutto e ricominciavo...imprecando dietro ad Android.
È stata trovata una soluzione al tuo problema?Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato .