Autore Topic: Il led non si accende!  (Letto 1779 volte)

Offline bobo78

  • Utente junior
  • **
  • Post: 55
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    nexus one
  • Sistema operativo:
    Win XP
Il led non si accende!
« il: 24 Ottobre 2011, 16:03:49 CEST »
0
Ciao a tutti e scusate se riprendo questo thread gia' risolto, ma non riesco ad accendere in nessun modo i led.
Ho provato sia su nexus s che su nexus one ma niente da fare.

Qualcuno c'e' riuscito su questi due telefoni?

Grazie mille.

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Il led non si accende!
« Risposta #1 il: 24 Ottobre 2011, 16:11:55 CEST »
0
Ciao a tutti e scusate se riprendo questo thread gia' risolto, ma non riesco ad accendere in nessun modo i led.
Ho provato sia su nexus s che su nexus one ma niente da fare.

Qualcuno c'e' riuscito su questi due telefoni?

Su nexus s mi pare che il led non ci sia (o debba essere abilitato con qualche kernel particolare).
Su nexus one a me funziona con il codice che è stato postato.

Offline bobo78

  • Utente junior
  • **
  • Post: 55
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    nexus one
  • Sistema operativo:
    Win XP
Re:Il led non si accende!
« Risposta #2 il: 24 Ottobre 2011, 16:42:37 CEST »
0
Su nexus s mi pare che il led non ci sia (o debba essere abilitato con qualche kernel particolare).
Su nexus one a me funziona con il codice che è stato postato.

Davvero? L'ho appena ritestato ma non mi funziona. Non capisco...
Se ce l'hai a portata di mano mi passeresti il tuo apk? Giusto per verificare che funzioni escludo la possibilita' di introdurre qualche errore. Se l'apk funziona sul tuo nexus one, allora deve funzionare anche sul mio...

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Il led non si accende!
« Risposta #3 il: 24 Ottobre 2011, 16:44:45 CEST »
0
Davvero? L'ho appena ritestato ma non mi funziona. Non capisco...
Se ce l'hai a portata di mano mi passeresti il tuo apk? Giusto per verificare che funzioni escludo la possibilita' di introdurre qualche errore. Se l'apk funziona sul tuo nexus one, allora deve funzionare anche sul mio...

Prova ad inserire il codice come descritto qui:

Status Bar Notifications | Android Developers

Offline bobo78

  • Utente junior
  • **
  • Post: 55
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    nexus one
  • Sistema operativo:
    Win XP
Re:Il led non si accende!
« Risposta #4 il: 24 Ottobre 2011, 17:03:18 CEST »
0
Prova ad inserire il codice come descritto qui:

Status Bar Notifications | Android Developers

Niente Da fare :-(
Per testare se la notifica e' stata creata correttamente, ho sostituito il led con la vibrazione e funziona. Ho dovuto includere la permissione nel manifest...
Niente da fare per il led  :'(

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Il led non si accende!
« Risposta #5 il: 24 Ottobre 2011, 17:24:42 CEST »
0
Ma con altri programmi funziona?

Offline bobo78

  • Utente junior
  • **
  • Post: 55
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    nexus one
  • Sistema operativo:
    Win XP
Re:Il led non si accende!
« Risposta #6 il: 24 Ottobre 2011, 17:26:38 CEST »
0
Ma con altri programmi funziona?

Fatti da me no. Con whatsapp riesco ad accenderlo in un sacco di colori diversi. Non saprei.

Se tu hai un codice che funziona sul tuo nexus, potrei provarlo sul mio...

Grazie mille

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Il led non si accende!
« Risposta #7 il: 24 Ottobre 2011, 17:29:29 CEST »
0
Io l'ho copiato pari pari dal sito che ti ho linkato.
Se vuoi postare il tuo codice vediamo se magari c'è qualche errore che ti sfugge :)

[edit]
Ho diviso il thread in modo da non inquinare quello già risolto ;)

Offline bobo78

  • Utente junior
  • **
  • Post: 55
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    nexus one
  • Sistema operativo:
    Win XP
Re:Il led non si accende!
« Risposta #8 il: 24 Ottobre 2011, 17:40:37 CEST »
0
Allora, il codice in cui ho inserito l'accensione del led e' il tutorial delle mappe (TutorialGPSeMapView).

Ho dichiarato glocali:
Codice (Java): [Seleziona]
   
int nodificationId;
NotificationManager objNotificationManager;

Poi ho inserito all'interno della classe activity principale queste due funzioni:
Codice (Java): [Seleziona]
    public void startNotification() {
        objNotificationManager = ( NotificationManager ) getSystemService( Context.NOTIFICATION_SERVICE );
        Notification notification = new Notification();
       
        notification.defaults |= Notification.DEFAULT_LIGHTS;
       
        notification.ledARGB = 0xff00ff00;
        notification.ledOnMS = 300;
        notification.ledOffMS = 1000;
        notification.flags |= Notification.FLAG_SHOW_LIGHTS;
       
        /*notification.defaults |= Notification.DEFAULT_VIBRATE;        
       
        long[] vibrate = {0,100,200,300};
        notification.vibrate = vibrate;*/

       
        nodificationId = (int)System.currentTimeMillis();
        objNotificationManager.notify(nodificationId, notification);
    }
   
    public void stopNotification() {
        if(objNotificationManager != null){
                objNotificationManager.cancel(nodificationId);
        }
    }


poi chiamo in "OnResume()"  "startNotification()" e in "OnPause()" chiamo stopNotification()

Cosa sto trascurando?

Grazie mille per l'aiuto


Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Il led non si accende!
« Risposta #9 il: 24 Ottobre 2011, 17:45:36 CEST »
0
Prova a fare così:

Codice (Java): [Seleziona]
notification.flags = Notification.FLAG_SHOW_LIGHTS;
notification.ledARGB = 0xff00ff00;
notification.ledOnMS = 300;
notification.ledOffMS = 1000;

Offline bobo78

  • Utente junior
  • **
  • Post: 55
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    nexus one
  • Sistema operativo:
    Win XP
Re:Il led non si accende!
« Risposta #10 il: 24 Ottobre 2011, 17:53:30 CEST »
0
Prova a fare così:

Codice (Java): [Seleziona]
notification.flags = Notification.FLAG_SHOW_LIGHTS;
notification.ledARGB = 0xff00ff00;
notification.ledOnMS = 300;
notification.ledOffMS = 1000;


Niente da fare  :'(
Ma c'e' qualcosa da scrivere nel manifest?





Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3489
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Il led non si accende!
« Risposta #11 il: 24 Ottobre 2011, 18:03:53 CEST »
0

Niente da fare  :'(
Ma c'e' qualcosa da scrivere nel manifest?


No non c'è niente.
Comunque questo è il codice che uso io...

Codice (Java): [Seleziona]
notification.defaults = 0;
notification.defaults |= Notification.DEFAULT_SOUND;
notification.defaults |= Notification.DEFAULT_VIBRATE;
notification.ledARGB = 0xff00ff00; // Green
notification.flags = Notification.FLAG_SHOW_LIGHTS;
notification.ledOnMS = 100;
notification.ledOffMS = 100;

Offline bobo78

  • Utente junior
  • **
  • Post: 55
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    nexus one
  • Sistema operativo:
    Win XP
Re:Il led non si accende!
« Risposta #12 il: 24 Ottobre 2011, 18:16:15 CEST »
0
Adesso suona e vibra ma niente led :(

Se vuoi posso provare il tuo apk sul mio nexus one...

Offline blackgin

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 1387
  • Respect: +164
    • Google+
    • blackgins
    • blackginsoft
    • Mostra profilo
  • Dispositivo Android:
    Galaxy Nexus
  • Sistema operativo:
    Mac OSX 10.8
Re:Il led non si accende!
« Risposta #13 il: 24 Ottobre 2011, 19:35:36 CEST »
0
Adesso suona e vibra ma niente led :(

Se vuoi posso provare il tuo apk sul mio nexus one...
Può essere che il led si accende solo a schermo spento?
Postate il LogCat LogCat LogCat LogCat LogCat

Offline Nicola_D

  • Utente storico
  • *****
  • Post: 2479
  • SBAGLIATO!
  • Respect: +323
    • Github
    • Google+
    • nicoladorigatti
    • Mostra profilo
  • Dispositivo Android:
    Nexus 6p, Nexus 4, Nexus S, Nexus 7(2012)
  • Sistema operativo:
    Windows 7
Re:Il led non si accende!
« Risposta #14 il: 24 Ottobre 2011, 19:55:26 CEST »
0
Può essere che il led si accende solo a schermo spento?
il led da quelle notifiche, dovrebbe essere quello in alto vicino all'altoparlante, che si accende solo se scolleghi il cavo usb...
IMPORTANTE:NON RISPONDO A PROBLEMI VIA MESSAGGIO PRIVATO
LOGCAT: Non sai cos'è? -> Android Debug Bridge | Android Developers
               Dov'è in Eclipse? -> Window -> Open Prospective -> DDMS e guarda in basso!
[Obbligatorio] Logcat, questo sconosciuto! (Gruppo AndDev.it LOGTFO) - Android Developers Italia