Autore Topic: Emulatore 2.1  (Letto 1038 volte)

Offline tuttoweb

  • Nuovo arrivato
  • *
  • Post: 13
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Xpedia x8
  • Sistema operativo:
    ubuntu 10.10
Emulatore 2.1
« il: 10 Agosto 2011, 21:30:45 CEST »
0
Ciao a tutti,
mi sto avviando alla programmazione per android. Non so ancora quasi niente, a parte che i programmi vanno scritti in Java.
Ho creato un AVD, ma non parte. Quando faccio run, parte l'emulatore, spunt ANDROID e poi niente! Ho atteso tempi lunghissimi (sono andato a pranzo e ancora niente). Usando 2.3 oppure 3.0 va tutto bene, eccetto che impiego sempre tempi titanici prima di poter testare le applicazioni.
Cosa posso fare? Ci sono dei trick & tips che posso leggere per creare un'emulazione fedele? Ho visto che ci stanno un sacco di parametri e non vorrei che abbia lasciato qualcosa al caso.
Vi ringrazio anticipatamente

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Emulatore 2.1
« Risposta #1 il: 11 Agosto 2011, 00:25:58 CEST »
0
Dunque, ormai credo di poter dire che l'emulatore honeycomb (3.x) è completamente INUSABILE. L'ho provato su una macchina di ultimissima generazione (core-i7 con 6GB ram win7 64bit) ed lentissimo. Quindi, eviterei di fare AVD con 3.x .

Usa i 2.x e possibilmente con schermi piccoli (si, è la risoluzione dello schermo che pesa). A quel punto i tempi geologici diventano quasi sopportabili.

Se vuoi sviluppare attivamente per tablet, l'unica opzione attuale è comprarsi il tablet e usarlo come target.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline tuttoweb

  • Nuovo arrivato
  • *
  • Post: 13
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Xpedia x8
  • Sistema operativo:
    ubuntu 10.10
Re:Emulatore 2.1
« Risposta #2 il: 11 Agosto 2011, 09:37:21 CEST »
0
Dunque, ormai credo di poter dire che l'emulatore honeycomb (3.x) è completamente INUSABILE. L'ho provato su una macchina di ultimissima generazione (core-i7 con 6GB ram win7 64bit) ed lentissimo. Quindi, eviterei di fare AVD con 3.x .

Usa i 2.x e possibilmente con schermi piccoli (si, è la risoluzione dello schermo che pesa). A quel punto i tempi geologici diventano quasi sopportabili.

Se vuoi sviluppare attivamente per tablet, l'unica opzione attuale è comprarsi il tablet e usarlo come target.
Infatti, io vorrei usare l'emulate 2.1, ma non funziona. Come dicevo, parte, spunta la scritta Android e stop. Cosa posso sistemare?

Offline ALEX88-ANDR0!D

  • Utente normale
  • ***
  • Post: 173
  • The Special One
  • Respect: +13
    • Google+
    • droidev88
    • Mostra profilo
  • Dispositivo Android:
    HTC DESIRE HD
  • Sistema operativo:
    WINDOWS 7
Re:Emulatore 2.1
« Risposta #3 il: 16 Agosto 2011, 00:40:07 CEST »
0
la prima cosa che mi viene in mentre hai installato sun java 6 http://www.anddev.it/index.php/topic,885.0.html premetto che non utilizzo ubuntu per programmare quindi non so i passaggi da fare per installare tutto il necessario per programmare per android su tale sistema , ma cercando su google ho trovato questa guida passo passo in inglesehttp://onthefencedevelopment.com/?p=455 , questa seconda in italiano http://www.ilpestifero.net/2011/03/23/sviluppare-per-android-su-ubuntu-setup/
« Ultima modifica: 16 Agosto 2011, 00:42:46 CEST da ALEX88-ANDR0!D »
È stata trovata una soluzione al tuo problema?
Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato ;).
E se hai aperto tu il thread marcalo come risolto cliccando !

Offline tuttoweb

  • Nuovo arrivato
  • *
  • Post: 13
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Xpedia x8
  • Sistema operativo:
    ubuntu 10.10
Re:Emulatore 2.1
« Risposta #4 il: 17 Agosto 2011, 11:19:12 CEST »
0
la prima cosa che mi viene in mentre hai installato sun java 6 http://www.anddev.it/index.php/topic,885.0.html premetto che non utilizzo ubuntu per programmare quindi non so i passaggi da fare per installare tutto il necessario per programmare per android su tale sistema , ma cercando su google ho trovato questa guida passo passo in inglesehttp://onthefencedevelopment.com/?p=455 , questa seconda in italiano http://www.ilpestifero.net/2011/03/23/sviluppare-per-android-su-ubuntu-setup/
grazie lo stesso, ma alla fine ho risolto.
A quanto pare se uno smanetta troppo con le AVD, ad un certo punto danno i numeri. Infatti, cancellandole e rifacendole tutto funziona. Non ricordo dove averlo letto però :D