Autore Topic: problemi con la MapActivity  (Letto 1065 volte)

Offline cha

  • Nuovo arrivato
  • *
  • Post: 28
  • Respect: 0
    • Mostra profilo
problemi con la MapActivity
« il: 04 Luglio 2011, 18:41:07 CEST »
0
salve, ho un problema con la visualizzazione di una semplice mappa. Il problema non è di certo nel codice perchèl'ho passato per mail al mio professore e a lui va perfettamente. Dunque è nell'ambiente. Io uso XP, per le API il livello 7, l'APIkey ce l'ho, nel preference->android->build c'è il giusto percorso per quanto riguarda la debug keystore. Ho letto on-line, fatto ogni tipo di prova, ma n riesco a risolvere il problema. di seguito vi posto il semplice codice e il logcat:

attività:
Codice: [Seleziona]
package eser.mappe;

import com.google.android.maps.MapActivity;
import android.os.Bundle;

public class MappaActivity extends MapActivity {
    /** Called when the activity is first created. */
    @Override
    public void onCreate(Bundle savedInstanceState) {
        super.onCreate(savedInstanceState);
        setContentView(R.layout.main);
    }
    @Override
    protected boolean isRouteDisplayed() {
        return false;
    }

main:
Codice: [Seleziona]
<?xml version="1.0" encoding="utf-8"?>
<LinearLayout xmlns:android="http://schemas.android.com/apk/res/android"
    android:orientation="vertical"
    android:layout_width="fill_parent"
    android:layout_height="fill_parent"
    >
<TextView 
    android:layout_width="fill_parent"
    android:layout_height="wrap_content"
    android:text="@string/hello"
    />
    <com.google.android.maps.MapView
            xmlns:android="http://schemas.android.com/apk/res/android"
            android:id="@+id/mapview"
            android:layout_width="fill_parent"
            android:layout_height="fill_parent"
            android:clickable="true"
            android:apiKey="0neFhyZhiq94k2jN5hwKWWpzGo9ZEq1-wDYqcVA"
        />
</LinearLayout>

manifesto:
Codice: [Seleziona]
<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
      package="eser.mappe"
      android:versionCode="1"
      android:versionName="1.0">
    <uses-sdk android:minSdkVersion="7" />

    <application android:icon="@drawable/icon" android:label="@string/app_name">
            <uses-library android:name="com.google.android.maps" />
        <activity android:name=".MappaActivity"
                  android:label="@string/app_name">
            <intent-filter>
                <action android:name="android.intent.action.MAIN" />
                <category android:name="android.intent.category.LAUNCHER" />
            </intent-filter>
        </activity>
         <uses-permission android:name="android.permission.INTERNET" />
    </application>
</manifest>

spero riusciate a dirmi in cosa sto sbagliando.

grazie,
saluti...

Offline cha

  • Nuovo arrivato
  • *
  • Post: 28
  • Respect: 0
    • Mostra profilo
Re:problemi con la MapActivity
« Risposta #1 il: 04 Luglio 2011, 18:43:21 CEST »
0
e questo è il logcat:
Codice: [Seleziona]
07-04 16:42:33.975: DEBUG/AndroidRuntime(404): >>>>>>>>>>>>>> AndroidRuntime START <<<<<<<<<<<<<<
07-04 16:42:33.996: DEBUG/AndroidRuntime(404): CheckJNI is ON
07-04 16:42:35.058: DEBUG/AndroidRuntime(404): --- registering native functions ---
07-04 16:42:38.346: INFO/ActivityManager(61): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10000000 cmp=eser.mappe/.MappaActivity }
07-04 16:42:39.506: DEBUG/AndroidRuntime(404): Shutting down VM
07-04 16:42:39.535: DEBUG/dalvikvm(404): DestroyJavaVM waiting for non-daemon threads to exit
07-04 16:42:39.555: DEBUG/dalvikvm(404): DestroyJavaVM shutting VM down
07-04 16:42:39.555: DEBUG/dalvikvm(404): HeapWorker thread shutting down
07-04 16:42:39.568: DEBUG/dalvikvm(404): HeapWorker thread has shut down
07-04 16:42:39.575: DEBUG/jdwp(404): JDWP shutting down net...
07-04 16:42:39.575: DEBUG/jdwp(404): Got wake-up signal, bailing out of select
07-04 16:42:39.575: INFO/dalvikvm(404): Debugger has detached; object registry had 1 entries
07-04 16:42:39.590: DEBUG/dalvikvm(404): VM cleaning up
07-04 16:42:39.676: ERROR/AndroidRuntime(404): ERROR: thread attach failed
07-04 16:42:39.947: DEBUG/dalvikvm(404): LinearAlloc 0x0 used 638076 of 5242880 (12%)
07-04 16:42:40.055: ERROR/ActivityThread(384): Failed to find provider info for com.google.settings
07-04 16:42:40.076: ERROR/ActivityThread(384): Failed to find provider info for com.google.settings
07-04 16:42:40.087: WARN/MapActivity(384): Recycling dispatcher com.google.googlenav.datarequest.DataRequestDispatcher@44e8d3d8
07-04 16:42:40.534: VERBOSE/MapActivity(384): Recycling map object.
07-04 16:42:41.536: INFO/MapActivity(384): Handling network change notification:CONNECTED
07-04 16:42:41.547: ERROR/MapActivity(384): Couldn't get connection factory client
07-04 16:42:42.076: INFO/ActivityManager(61): Displayed activity eser.mappe/.MappaActivity: 2480 ms (total 2480 ms)
07-04 16:42:47.578: DEBUG/dalvikvm(109): GC freed 172 objects / 7328 bytes in 390ms

Offline cha

  • Nuovo arrivato
  • *
  • Post: 28
  • Respect: 0
    • Mostra profilo
Re:problemi con la MapActivity
« Risposta #2 il: 07 Luglio 2011, 11:51:33 CEST »
0
ho rinstallato tutto e rigenerato un apikey e ora funziona.