Autore Topic: problema insolito : risorse  (Letto 404 volte)

Offline _SC_

  • Nuovo arrivato
  • *
  • Post: 20
  • Respect: 0
    • Mostra profilo
problema insolito : risorse
« il: 10 Giugno 2011, 10:18:48 CEST »
0
Ho un insolito e mYsterioso problema con un progettino.

Se faccio clean (uso eclipse) del progetto sparisce la cartella generata (gen) e non compila più (non c'è più R).
Per risolvere il problema devo fare :
importo android.R ( import android.R ;)
poi lo cancello, semplicemente cancello la riga con il build automatico settato
e magicamente ricompare il gen e tutto è a posto...

Non riesco a capire, l'unica cosa che mi viene in mente è che il clean di eclipse faccia cose diverse dalla build automatica... o_O

Qualcuno ha mai avuto questo problema e sa perchè si verifica?

Offline Nicola_D

  • Utente storico
  • *****
  • Post: 2479
  • SBAGLIATO!
  • Respect: +323
    • Github
    • Google+
    • nicoladorigatti
    • Mostra profilo
  • Dispositivo Android:
    Nexus 6p, Nexus 4, Nexus S, Nexus 7(2012)
  • Sistema operativo:
    Windows 7
Re:problema insolito : risorse
« Risposta #1 il: 10 Giugno 2011, 10:32:59 CEST »
0
i clean cancella le cose generate, il build le compila!
a che ti serve il clean? build sovrascrive da solo le cose che deve.
a volte può servire fare il clean,ma sono casi piu unici che rari in progetti piccolini
IMPORTANTE:NON RISPONDO A PROBLEMI VIA MESSAGGIO PRIVATO
LOGCAT: Non sai cos'è? -> Android Debug Bridge | Android Developers
               Dov'è in Eclipse? -> Window -> Open Prospective -> DDMS e guarda in basso!
[Obbligatorio] Logcat, questo sconosciuto! (Gruppo AndDev.it LOGTFO) - Android Developers Italia