Autore Topic: HelloGoogleMaps - mappa grigia  (Letto 1375 volte)

Offline ermoro77

  • Nuovo arrivato
  • *
  • Post: 3
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    LG Optimus Dual
  • Play Store ID:
    Roma
  • Sistema operativo:
    Windows XP
HelloGoogleMaps - mappa grigia
« il: 18 Maggio 2011, 18:51:53 CEST »
0
Ciao A tutti, sono nuovo del forum e della programmazione Android, sto eseguendo i tutorials di Android Developers.
Nell'eseguire il tutorial in oggetto l'applicazione parte correttamente ma non riesco ad ottenere la mappa, nonostante abbia prelevato e configurato la apiKey secondo le regole.

Nè dal log della console di eclipse, nè dalla vista degli errori si evince nulla.

Sto impazzendo: secondo me si potrebbe trattare del firewall aziendale o del settaggio del proxy, però vi dico che dopo la configurazione dell'ultimo sono riuscito ad installare correttamente le Google API in Eclipse.

Potete aiutare un neofita sviluppatore Android?

Grazie ragazzi.  ;-)

Offline pburatti

  • Nuovo arrivato
  • *
  • Post: 7
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Galaxy S
  • Sistema operativo:
    windows XP
Re:HelloGoogleMaps - mappa grigia
« Risposta #1 il: 20 Maggio 2011, 14:51:54 CEST »
0
Ciao anche io come te, ho seguito tutte le istruzioni per provare l'esempio del tutorial, ma continuo a non vedere le mappe (griglia bianca).
Ho reinstallato sdk java e quella di android, ho richiesto una nuova chiave a partire dall'md5 calcolato ma niente non sembra andare.
Ho ricontrollato la chiave inserita nel main.xml ed è corretta.
Cos'è che mi sto perdendo?

La cosa strana è che dopo la reinstallazione delle sdk ho ottenuto lo stesso md5 per il file debug.keystore e quindi ottenuto la stessa chiave da google.

Per il resto ho eseguito alla lettera tutto il tutorial.
Altra informazione: tramite l'emulatore mi connetto ad internet con il browser, quindi la connessione alla rete è ok.

Offline ermoro77

  • Nuovo arrivato
  • *
  • Post: 3
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    LG Optimus Dual
  • Play Store ID:
    Roma
  • Sistema operativo:
    Windows XP
Re:HelloGoogleMaps - mappa grigia
« Risposta #2 il: 20 Maggio 2011, 16:17:02 CEST »
0
Grazie della tua comunicazione, anch'io come te ho instalalto un'altra versione del JDK ed ottenuto la stessa apikey da google!
A questo punto la domanda sorge spontanea: ma la key viaggia di pari passo con l'indirizzo ip del richiedente? O cosa?
Perchè viene fornita la stessa key anche richiedendola da un'altra versione del JDK?

Ad ulteriore informazione aggiungo che io no, non riesco a navigare dal browser dell'emulatore nonostante appaia l'icona 3G!!! Perchè?!? Mah!!!

Ad applicazione startata la mappa appare grigia e non bianca come la tua!

Help, thx!

Offline pburatti

  • Nuovo arrivato
  • *
  • Post: 7
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Galaxy S
  • Sistema operativo:
    windows XP
Re:HelloGoogleMaps - mappa grigia
« Risposta #3 il: 20 Maggio 2011, 18:13:53 CEST »
0
Comunque penso che il tuo problema sia il fatto che non hai abilitato il modulo gsm e il modulo gps nel tuo emulatore. Inoltre verifica che la rete a cui ti connetti passa per un proxy. Questo potrebbe dare problemi.

Offline ermoro77

  • Nuovo arrivato
  • *
  • Post: 3
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    LG Optimus Dual
  • Play Store ID:
    Roma
  • Sistema operativo:
    Windows XP
Re:HelloGoogleMaps - mappa grigia
« Risposta #4 il: 20 Maggio 2011, 18:37:01 CEST »
0
cosa intendi per modulo GSM?!? il modulo GPS se vado a verificare nelle impostrazioni è attivo!

Grazie

Offline Ivan86

  • Utente junior
  • **
  • Post: 139
  • Respect: +1
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy S II
  • Sistema operativo:
    Windows 7
Re:HelloGoogleMaps - mappa grigia
« Risposta #5 il: 18 Ottobre 2012, 11:46:40 CEST »
0
Ciao a tutti.

Sfrutto questo topic per non aprirne un altro. Magari dopo tanto tempo qualcuno è incappato in questo problema.

Allora il problema è su per giù il medesimo.
Ho la mia App da più di un anno e da qualche giorno (ma forse è successo anche da prima) non vedo più le mappe sul mio cell e su quello degli altri.
Quando lancio l'emulatore riesco a vederle perfettamente. Una volta installato l'apk sul cellulare, rimane schermata grigia. (I POI si vedono perfettamente).

Ho provato a rigenerare la apikey dallo stesso pc, ma anche io ho constatato che la chiave generata è la stessa.
Ho provato a generarne un'altra da un altro pc, ma il problema persiste.

Sapete aiutare?