Autore Topic: Problema VM-Emulatore  (Letto 360 volte)

Offline TheWorstEver_

  • Nuovo arrivato
  • *
  • Post: 22
  • Respect: +1
    • Mostra profilo
  • Dispositivo Android:
    Sony Ericsson Xperia 10 Mini
  • Sistema operativo:
    Windows 7
Problema VM-Emulatore
« il: 21 Aprile 2011, 12:28:25 CEST »
0
Ciao a tutti,

ho un problema con la virtual machine, o emulatore, sostanzialmente quando avvio un programma da testare, qualsiasi sia, inizia a dare errori il .launcher.
che continua a dare errore e riavviarsi, di continuo.

Riporto l'errore del logcat, Avete idee di perchè non riesca a allocare i 39Mbyte necessari?

Codice: [Seleziona]
I/ActivityManager(   71): Displayed activity com.android.launcher/com.android.launcher2.Launcher: 1948 ms (total 1948 ms)
E/dalvikvm-heap(  380): 39302978-byte external allocation too large for this process.
E/GraphicsJNI(  380): VM won't let us allocate 39302978 bytes
W/dalvikvm(  380): threadid=7: thread exiting with uncaught exception (group=0x4001d800)
E/AndroidRuntime(  380): FATAL EXCEPTION: Thread-8
E/AndroidRuntime(  380): java.lang.OutOfMemoryError: bitmap size exceeds VM budget

Ps. ho provato a testare il programma su altre macchine, e funziona tutto perfettamente.
PPs. ho un computer con window 7, i7, 6 Gbyte di ram, Ati radeon 5830 ect ect... Quando lo ho assemblato ho avuto un problema a lvl di frequenza tra ram e cpu, però settando adeguatamente i bios, tutto gira perfettamente. Prima pensavo che il problema poteva riguardare qualche conflitto tra loro due, ma lo vedo impossibile.

Idee?

Grazie mille di essere passati.