Autore Topic: Problema nell'utilizzare più emulatori.  (Letto 1640 volte)

Offline Prometeo6

  • Nuovo arrivato
  • *
  • Post: 5
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Windows
Problema nell'utilizzare più emulatori.
« il: 22 Febbraio 2011, 14:57:52 CET »
0
Ciao, sono nuovo del Forum.

Ho un problema nell'utilizzare più istanze di emulatori contemporaneamente.

In particolare avvio 3 device virtuali separati, e su ognuna di queste cerco di avviare un'applicazione. Queste applicazioni comunicano tra di loro per scambiarsi informazioni.

Il mio problema si verifica quando cerco di installare la terza applicazione sul terzo device. Sulla Console ricevo questo errore:

Codice: [Seleziona]
[2011-02-22 13:03:16 - adb]This application has requested the Runtime to terminate it in an unusual way.
[2011-02-22 13:03:16 - adb]Please contact the application's support team for more information.
[2011-02-22 13:03:16 - DeviceMonitor]Adb connection Error:Connessione in corso interrotta forzatamente dall'host remoto
[2011-02-22 13:03:18 - DeviceMonitor]Connection attempts: 1
[2011-02-22 13:03:20 - DeviceMonitor]Connection attempts: 2
[2011-02-22 13:03:22 - DeviceMonitor]Connection attempts: 3
[2011-02-22 13:03:24 - DeviceMonitor]Connection attempts: 4
[2011-02-22 13:03:26 - DeviceMonitor]Connection attempts: 5
[2011-02-22 13:03:28 - DeviceMonitor]Connection attempts: 6
[2011-02-22 13:03:30 - DeviceMonitor]Connection attempts: 7
[2011-02-22 13:03:32 - DeviceMonitor]Connection attempts: 8
[2011-02-22 13:03:34 - DeviceMonitor]Connection attempts: 9
[2011-02-22 13:03:36 - DeviceMonitor]Connection attempts: 10
[2011-02-22 13:03:38 - DeviceMonitor]Connection attempts: 11

Non riesco a capire da cosa dipende  :-(. Le porte dei device sono la 5554, la 5556 e la 5558.

Se invece avvio due device funzionano perfettamente.

Grazie a tutti.
« Ultima modifica: 24 Febbraio 2011, 17:59:24 CET da Ricky` »

Offline JD

  • Amministratore
  • Utente storico
  • *****
  • Post: 1600
  • Respect: +232
    • leinardi
    • Mostra profilo
  • Dispositivo Android:
    LG Nexus 5
  • Sistema operativo:
    L'ultima Ubuntu
Re:Problema nell'utilizzare più emulatori.
« Risposta #1 il: 23 Febbraio 2011, 04:50:25 CET »
0
Il problema si presenta solo con quella specifica applicazione o non riesci ad installare nessuna app sul terzo device?
È stata trovata una soluzione al tuo problema?
Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato ;).
E se hai aperto tu il thread marcalo come risolto cliccando !

Offline Prometeo6

  • Nuovo arrivato
  • *
  • Post: 5
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Windows
Re:Problema nell'utilizzare più emulatori.
« Risposta #2 il: 23 Febbraio 2011, 09:35:43 CET »
0
Purtroppo non riesco a installare nessuna applicazione sul terzo device :(.

Offline JD

  • Amministratore
  • Utente storico
  • *****
  • Post: 1600
  • Respect: +232
    • leinardi
    • Mostra profilo
  • Dispositivo Android:
    LG Nexus 5
  • Sistema operativo:
    L'ultima Ubuntu
Re:Problema nell'utilizzare più emulatori.
« Risposta #3 il: 23 Febbraio 2011, 13:56:46 CET »
0
Il problema ce l'ha un qualunque AVD in ascolto sulla porta 5558 o lo da un AVD specifico? Hai provato ad avviarli con una sequenza differente? Cancellare e ricreare gli AVD?
È stata trovata una soluzione al tuo problema?
Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato ;).
E se hai aperto tu il thread marcalo come risolto cliccando !

Offline Prometeo6

  • Nuovo arrivato
  • *
  • Post: 5
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Windows
Re:Problema nell'utilizzare più emulatori.
« Risposta #4 il: 23 Febbraio 2011, 18:01:24 CET »
0
Si, il problema c'è con qualunque AVD in ascolto sulla 5558. Ho provato anche ad avviarli con sequenze diverse e ho anche cancellato e ricreato più volte gli AVD.

Offline JD

  • Amministratore
  • Utente storico
  • *****
  • Post: 1600
  • Respect: +232
    • leinardi
    • Mostra profilo
  • Dispositivo Android:
    LG Nexus 5
  • Sistema operativo:
    L'ultima Ubuntu
Re:Problema nell'utilizzare più emulatori.
« Risposta #5 il: 23 Febbraio 2011, 18:41:10 CET »
0
Hai provato ad avviarne 4? Il problema c'è solo con la 5558 o con qualunque porta maggiore di 5556?

Io cmq ne ho usato anche 5 contemporaneamente + dispositivo fisico.
È stata trovata una soluzione al tuo problema?
Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato ;).
E se hai aperto tu il thread marcalo come risolto cliccando !

Offline Prometeo6

  • Nuovo arrivato
  • *
  • Post: 5
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Windows
Re:Problema nell'utilizzare più emulatori.
« Risposta #6 il: 24 Febbraio 2011, 09:39:30 CET »
0
Ho provato a lanciare 4 istanze e questa volta la terza applicazione l'ho lanciata sul device in ascolto sulla porta 5560 ma nulla, sulla console ricevo:

Codice: [Seleziona]
[2011-02-24 09:36:11 - adb]
[2011-02-24 09:36:11 - adb]This application has requested the Runtime to terminate it in an unusual way.
[2011-02-24 09:36:11 - adb]Please contact the application's support team for more information.
[2011-02-24 09:36:11 - DeviceMonitor]Adb connection Error:Connessione in corso interrotta forzatamente dall'host remoto
[2011-02-24 09:36:11 - Logcat]Connessione in corso interrotta forzatamente dall'host remoto
java.io.IOException: Connessione in corso interrotta forzatamente dall'host remoto
        at sun.nio.ch.SocketDispatcher.read0(Native Method)
        at sun.nio.ch.SocketDispatcher.read(Unknown Source)
        at sun.nio.ch.IOUtil.readIntoNativeBuffer(Unknown Source)
        at sun.nio.ch.IOUtil.read(Unknown Source)
        at sun.nio.ch.SocketChannelImpl.read(Unknown Source)
        at com.android.ddmlib.AdbHelper.executeRemoteCommand(AdbHelper.java:395)
        at com.android.ddmlib.Device.executeShellCommand(Device.java:284)
        at com.android.ddmuilib.logcat.LogPanel$3.run(LogPanel.java:527)

[2011-02-24 09:36:12 - DeviceMonitor]Connection attempts: 1
[2011-02-24 09:36:14 - DeviceMonitor]Connection attempts: 2
[2011-02-24 09:36:16 - DeviceMonitor]Connection attempts: 3
[2011-02-24 09:36:18 - DeviceMonitor]Connection attempts: 4
[2011-02-24 09:36:20 - DeviceMonitor]Connection attempts: 5
[2011-02-24 09:36:22 - DeviceMonitor]Connection attempts: 6
[2011-02-24 09:36:24 - DeviceMonitor]Connection attempts: 7
[2011-02-24 09:36:26 - DeviceMonitor]Connection attempts: 8
[2011-02-24 09:36:28 - DeviceMonitor]Connection attempts: 9
[2011-02-24 09:36:30 - DeviceMonitor]Connection attempts: 10
[2011-02-24 09:36:32 - DeviceMonitor]Connection attempts: 11
« Ultima modifica: 24 Febbraio 2011, 17:59:45 CET da Ricky` »

Offline Nicola_D

  • Utente storico
  • *****
  • Post: 2479
  • SBAGLIATO!
  • Respect: +323
    • Github
    • Google+
    • nicoladorigatti
    • Mostra profilo
  • Dispositivo Android:
    Nexus 6p, Nexus 4, Nexus S, Nexus 7(2012)
  • Sistema operativo:
    Windows 7
Re:Problema nell'utilizzare più emulatori.
« Risposta #7 il: 24 Febbraio 2011, 11:14:10 CET »
0
che pc hai? sistema operativo, cpu,ram ecc...
e i 3 avd son tutti stessa versione? 2.2?
IMPORTANTE:NON RISPONDO A PROBLEMI VIA MESSAGGIO PRIVATO
LOGCAT: Non sai cos'è? -> Android Debug Bridge | Android Developers
               Dov'è in Eclipse? -> Window -> Open Prospective -> DDMS e guarda in basso!
[Obbligatorio] Logcat, questo sconosciuto! (Gruppo AndDev.it LOGTFO) - Android Developers Italia

Offline Prometeo6

  • Nuovo arrivato
  • *
  • Post: 5
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Windows
Re:Problema nell'utilizzare più emulatori.
« Risposta #8 il: 24 Febbraio 2011, 11:31:38 CET »
0
Le caratteristiche del mio pc sono queste:

 - Win Xp Professional Versione 2002 Service Pack 3
 - Intel Core(TM)2 Duo CPU T7250 @ 2.00 GHz
 - 2.00 GHz, 3,50 GB di RAM

I 3 avd sono tutti Platform 2.3.3, API Level 10.