Autore Topic: Problemi MapActivity ed emulatore  (Letto 809 volte)

Offline leon84

  • Nuovo arrivato
  • *
  • Post: 23
  • Respect: 0
    • Mostra profilo
Problemi MapActivity ed emulatore
« il: 18 Febbraio 2011, 12:07:38 CET »
0
Salve,
ho realizzato un app che fa uso delle api map di google. Ho firmato l'applicazione ed ottenuto la chiave google per le api regolarmente.
L'app utilizza le librerie della piattaforma android+google 2.2 (API level 8).
Se creo AVD 2.2 non riesco a visualizzare la mappa di google ma soltato l'overlay, se invece utilizzo AVD 2.3 funziona tutto perfettamente.
Poi ho installato l'app su un terminale android reale con versione 2.2 e funziona tutto bene.
Perché l'emulatore AVD 2.2 non funziona bene?

Offline Kappa27

  • Nuovo arrivato
  • *
  • Post: 43
  • Respect: +2
    • kevvort
    • Mostra profilo
  • Dispositivo Android:
    Galaxy Tab
  • Sistema operativo:
    Windows 7 x64 - Ubuntu 10.10
Re:Problemi MapActivity ed emulatore
« Risposta #1 il: 18 Febbraio 2011, 12:29:31 CET »
0
Penso che manchino le Google APIs  :-\

Offline leon84

  • Nuovo arrivato
  • *
  • Post: 23
  • Respect: 0
    • Mostra profilo
Re:Problemi MapActivity ed emulatore
« Risposta #2 il: 18 Febbraio 2011, 12:38:15 CET »
0
Come fanno a mancare le GoogleApi? Il target dell'AVD è Google API level 8.


Penso che manchino le Google APIs  :-\

Offline Kappa27

  • Nuovo arrivato
  • *
  • Post: 43
  • Respect: +2
    • kevvort
    • Mostra profilo
  • Dispositivo Android:
    Galaxy Tab
  • Sistema operativo:
    Windows 7 x64 - Ubuntu 10.10
Re:Problemi MapActivity ed emulatore
« Risposta #3 il: 18 Febbraio 2011, 16:46:37 CET »
0
Come fanno a mancare le GoogleApi? Il target dell'AVD è Google API level 8.
Non ha Google Maps, aspetta qualcuno di più esperto  :-P

Offline leon84

  • Nuovo arrivato
  • *
  • Post: 23
  • Respect: 0
    • Mostra profilo
Re:Problemi MapActivity ed emulatore
« Risposta #4 il: 21 Febbraio 2011, 12:43:01 CET »
0
up

Offline leon84

  • Nuovo arrivato
  • *
  • Post: 23
  • Respect: 0
    • Mostra profilo
Re:Problemi MapActivity ed emulatore
« Risposta #5 il: 21 Febbraio 2011, 14:52:03 CET »
0
Per maggiori info allego l'errore riportato nel LogCat ...


02-21 13:47:58.713: INFO/MapActivity(298): Handling network change notification:CONNECTED
02-21 13:47:58.713: ERROR/MapActivity(298): Couldn't get connection factory client
02-21 13:47:59.033: INFO/ActivityManager(58): Displayed activity com.utility.earthquake/.mappa: 2244 ms (total 2244 ms)