Autore Topic: errori nel progetto dopo aggiornamento  (Letto 146 volte)

Offline pain_antonx

  • Nuovo arrivato
  • *
  • Post: 7
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    huawei p9
  • Sistema operativo:
    Windows
errori nel progetto dopo aggiornamento
« il: 06 Novembre 2017, 23:04:20 CET »
0
Salve ragazzi, mentre facevo un po di pratica con android studio, mi ha chiesto di fare alcuni aggiornamenti. Purtroppo dopo aver terminato gli aggiornamenti, mi dà problemi nel file manifest.
L'errore è il seguente:
Error:(2) error: attribute 'package' in <manifest> tag is not a valid Java package name: 'com.example.pain_.provapp' e mi segna alcune righe in rosso come ad esempio:
<manifest xmlns:android="http://schemas.android.com/apk/res/android"     errore : uri is not registred
    package="com.example.pain.reddevilsapp" 
    android:versionCode="1"                             errore android:versionCode is not allowed here
    android:versionName="1.0" >                       errore android:versionName is not allowed here
Come posso risolvere questo strano probelma?
Grazie
« Ultima modifica: 07 Novembre 2017, 18:24:11 CET da pain_antonx »

Offline iClaude

  • Utente normale
  • ***
  • Post: 289
  • Respect: +21
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy S8
  • Sistema operativo:
    Windows 10
Re:errori nel progetto dopo aggiornamento
« Risposta #1 il: 07 Novembre 2017, 08:55:05 CET »
0
Prova a rimuovere l'underscore prima del punto nel package name.

Offline pain_antonx

  • Nuovo arrivato
  • *
  • Post: 7
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    huawei p9
  • Sistema operativo:
    Windows
Re:errori nel progetto dopo aggiornamento
« Risposta #2 il: 07 Novembre 2017, 10:37:20 CET »
0
Appena torno a casa provo a togliere l'underscore,ma comunque ci sono anche altre linee che mi segna in rosso.ma la cosa strana è che io il file manifest non l'ho toccato e anche se creo un nuovo progetto mi da lo stesso errore. Tutto questo dopo aver fatto l update

Post unito: [time]07 Novembre 2017, 18:01:17 CET[/time]
purtroppo non risolve il problema rimuovere l'underscore
   <application
    android:allowBackup="true" errore: allowbackup is not allowed here
        android:debuggable="true"   
        android:icon="@mipmap/ic_launcher" errore: android:icon is not allowed here
        android:label="@string/app_name"
        android:roundIcon="@mipmap/ic_launcher_round"    errore: android:roundIcon is not allowed here
        android:supportsRtl="true"                         errore:                       android:supportsRtl is not allowed here
        android:theme="@style/AppTheme" >             errore:         android:theme is not allowed here

Post unito: [time]07 Novembre 2017, 21:46:16 CET[/time]
ho notato che non riesce nemmeno a trovare riferimenti alla classe R. Suppongo che sia cambiato qualcosa nei path

Post unito: 07 Novembre 2017, 23:19:18 CET
Se qualcun'altro avesse lo stesso problema dopo l'aggiornamento ad android studio 3.0
https://stackoverflow.com/questions/42593758/gradle-error-after-updating-to-android-studio-2-3 <--- questo risolve il problema
« Ultima modifica: 07 Novembre 2017, 23:19:18 CET da pain_antonx, Reason: Merged DoublePost »