Autore Topic: Errori nel progetto dop aggiornamento Android Studio  (Letto 342 volte)

Offline Nicolab1971

  • Utente junior
  • **
  • Post: 110
  • Respect: +2
    • Mostra profilo
Errori nel progetto dop aggiornamento Android Studio
« il: 29 Ottobre 2017, 13:03:21 CET »
0
Dopo l'aggiornamento di ANdroid Studio alla versione 3 quando apro il progetto mi da questo errore:

Error:Unable to load class 'org.gradle.api.internal.component.Usage'.
Possible causes for this unexpected error include:<ul><li>Gradle's dependency cache may be corrupt (this sometimes occurs after a network connection timeout.)
<a href="syncProject">Re-download dependencies and sync project (requires network)</a></li><li>The state of a Gradle build process (daemon) may be corrupt. Stopping all Gradle daemons may solve this problem.
<a href="stopGradleDaemons">Stop Gradle build processes (requires restart)</a></li><li>Your project may be using a third-party plugin which is not compatible with the other plugins in the project or the version of Gradle requested by the project.</li></ul>In the case of corrupt Gradle processes, you can also try closing the IDE and then killing all Java processes.

Qualcuno sa di cosa si tratta?

Post unito: 29 Ottobre 2017, 13:14:48 CET
Mi rispondo da solo in questo progetto il problema risiedeva in una libreria che utilizza questo plugin bintray release, che sembra dare problemi di compatibilità. Tolto il plug al momento sembra compilare.

Comunque grazie
« Ultima modifica: 29 Ottobre 2017, 13:14:48 CET da Nicolab1971, Reason: Merged DoublePost »