Autore Topic: Api su versioni inferiori di Api  (Letto 291 volte)

Offline basicdany

  • Nuovo arrivato
  • *
  • Post: 9
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    huawei p9
  • Sistema operativo:
    windows 7
Api su versioni inferiori di Api
« il: 15 Luglio 2017, 11:54:14 CEST »
0
Salve ho realizzato la mia prima app api 23 android 6 , con android studio, nonostante ho messo come requisiti minimi SDK api 19 android 4.4 , dopo averla installata su Android 4.4     all'avvio mi dà errore e si chiude. Perché? Ci sono altre cose da impostare? Grazie spero qualcuno possa darmi qualche dritta....sono bloccato da parecchio....

Offline DCodeOS

  • Utente junior
  • **
  • Post: 84
  • Respect: +20
    • Mostra profilo
  • Sistema operativo:
    macOS Sierra
Re:Api su versioni inferiori di Api
« Risposta #1 il: 15 Luglio 2017, 12:33:42 CEST »
0
Aiutarti così e un po' complicato... Prova a postare il logcat dell'errore
┻━┻ ︵ヽ(°□°ヽ) Develop w/ ( ( ObjC || Swift ) && Java[ "Android" ] ) (╯°□°)╯︵ ┻━┻

Offline basicdany

  • Nuovo arrivato
  • *
  • Post: 9
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    huawei p9
  • Sistema operativo:
    windows 7
Re:Api su versioni inferiori di Api
« Risposta #2 il: 15 Luglio 2017, 17:16:13 CEST »
0
Ciao, ho risolto, impostando come max livello api nel android studio livello 23 anche se il mio cellulare che uso e livello 24 perché ha android 7.0.
Ho impostato poi livello api Min 19
Facendo così l ,'app realizzata funziona anche su cellulare con android 4.4 .

E strano....però funziona così, come se le api del livello 24 non funzionano con livello 19.....

Grazie comunque