Autore Topic: apk tablet  (Letto 490 volte)

Offline xixietto

apk tablet
« il: 14 Febbraio 2016, 16:00:24 CET »
0
Salve, ricevo questo su android delevolper
Codice (Java): [Seleziona]
Progetta la tua app per i tabletIl tuo APK di produzione deve soddisfare i seguenti criteri:
Il tuo APK dovrebbe richiedere solo le funzionalità hardware solitamente disponibili sui tablet. Leggi ulteriori informazioni

come fare l'app compatibile anche per tablet?

Offline dev91

  • Utente junior
  • **
  • Post: 51
  • Respect: +1
    • Mostra profilo
  • Dispositivo Android:
    Note 4
Re:apk tablet
« Risposta #1 il: 19 Febbraio 2016, 15:59:16 CET »
0
Salve, ricevo questo su android delevolper
Codice (Java): [Seleziona]
Progetta la tua app per i tabletIl tuo APK di produzione deve soddisfare i seguenti criteri:
Il tuo APK dovrebbe richiedere solo le funzionalità hardware solitamente disponibili sui tablet. Leggi ulteriori informazioni

come fare l'app compatibile anche per tablet?
Ciao, quali permessi richiede la tua App?

Offline xixietto

Re:apk tablet
« Risposta #2 il: 19 Febbraio 2016, 23:30:36 CET »
0
Vibrazione, inviare messaggi e chiamare, scrittura e lettura memoria esterna

Inviato dal mio GT-I9505 utilizzando Tapatalk


Offline dev91

  • Utente junior
  • **
  • Post: 51
  • Respect: +1
    • Mostra profilo
  • Dispositivo Android:
    Note 4
Re:apk tablet
« Risposta #3 il: 20 Febbraio 2016, 12:28:20 CET »
0
Vibrazione, inviare messaggi e chiamare, scrittura e lettura memoria esterna

Inviato dal mio GT-I9505 utilizzando Tapatalk

Il problema è che permessi come "inviare messaggi e chiamare", se obbligatori (come da impostazione di default di Android), non sono funzionalità disponibili su alcuni Tablet (non tutti hanno la SIM).
Se nella tua app sono permessi obbligatori, nel senso che le funzionalità da te implementate li utilizzano e non possono farne a meno, non puoi risolvere il problema.
In caso contrario utilizza l'attributo required="false":

Codice (XML): [Seleziona]
<uses-feature android:name="android.hardware.telephony" android:required="false" />