Autore Topic: non riesco a installare le google api  (Letto 1659 volte)

Offline Sam

  • Nuovo arrivato
  • *
  • Post: 29
  • Respect: 0
    • Mostra profilo
non riesco a installare le google api
« il: 30 Dicembre 2010, 17:16:33 CET »
0
Ho del codice di un progetto funzionante che usa delle google api e ovviamente è un errore unico visto che non mi vede gli import com.google. Ho ottenuto una map key e l'ho scambiata con quella residente nei file xml e ho appurato che ci fosse la riga di codice aggiuntiva nel manifest. A questo punto dovrebbe solo mancare di creare un avd che punta alle google api. Sto usando eclipse e sono andato in windows->androidsdk and avd->available package e ho installato l'occorrente delle google api. A questo punto creo il mio avd che però non fa riferimento a un campo google api ma all'ultimo sdk visto che nel menu a tendina non cè nulla di simile (spero sia già integrato in quello). Sono andato anche sul progetto tasto destro, proprietà->android e vede sempre l'ultima versione dell'sdk. Il progetto rimane però costellato di errori perchè non mi vede nessuna api.
è giusto che io punti all'ultimo sdk o deve esistere un campo google api? manca altro? Grazie dell'aiuto

Offline 7h38ugg3r

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 1200
  • Respect: +133
    • riccardofischetti
    • th38ugg3r
    • @7h38ugg3r
    • Mostra profilo
  • Dispositivo Android:
    Galaxy-S GT I-9000/ ASUS Eee Pad Transformer
  • Play Store ID:
    Riccardo Fischetti
  • Sistema operativo:
    OS X Lion / Linux Mint 11 (Katya)
Re:non riesco a installare le google api
« Risposta #1 il: 03 Gennaio 2011, 14:36:39 CET »
+1
Se hai installato tra i packages per AVD google api, dovresti vederli sia nella creazione dell'emulatore, sia nelle properties del progetto.
Per poter funzionare con le api google, il tuo progetto deve utilizzare quelle librerie, quindi prova a reinstallarle (magari qualche altra versione, per provare).
7h38ugg3r<=>thebugger
Non conosci Java? Allora sei nel posto sbagliato!

http://www.androidpatterns.com/

Offline JD

  • Amministratore
  • Utente storico
  • *****
  • Post: 1600
  • Respect: +232
    • leinardi
    • Mostra profilo
  • Dispositivo Android:
    LG Nexus 5
  • Sistema operativo:
    L'ultima Ubuntu
Re:non riesco a installare le google api
« Risposta #2 il: 03 Gennaio 2011, 16:30:22 CET »
+1
Dentro l'Android SDK and AVD Manager, in "Availaible  Packages"  seleziona e installa "SDK Platform Android 2.3, API9, revision 1" e "Google APIs by Google Inc., Android API 9, revision 1".
Elimina l'AVD che hai creato e creane uno nuovo selezionando come Target "Google APIs (Google Inc.) - API Level 9".
In Eclipse apri le proprietà del progetto -> Android -> Spunta Google APIs (API Level 9).

Se non vuoi usare l'API Level 9 sostituisci quel numero con l'API Level da te preferito (ti consiglio di non scendere sotto il 4).
È stata trovata una soluzione al tuo problema?
Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato ;).
E se hai aperto tu il thread marcalo come risolto cliccando !

Offline Sam

  • Nuovo arrivato
  • *
  • Post: 29
  • Respect: 0
    • Mostra profilo
Re:non riesco a installare le google api
« Risposta #3 il: 04 Gennaio 2011, 21:32:26 CET »
0
Oggi ho ripetuto l'installazione per l'ennesima volta ed è comparso google api   o_O mah
Grazie e scusate del disturbo