Autore Topic: compilazione appcompaq-v7 con eclipse  (Letto 906 volte)

Offline BruceAndDevIT

  • Nuovo arrivato
  • *
  • Post: 12
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    lg l5
  • Sistema operativo:
    windows seven
compilazione appcompaq-v7 con eclipse
« il: 15 Dicembre 2015, 16:14:54 CET »
0
salve a tutti

ho un problema dopo aver lottato tantissimo con android studio ho deciso di tornare allo sviluppo con eclipse
quindi ho iniziato una fase porting da android studio vs eclipse di un mio progetto.

le caratteristiche di questo progetto sono

che usa materialdesign + lib appcompac design ...

ho letto vari articoli e post su stackoverflow in cui spiegava come compilare in eclipse la lib appcompav7

ho provato ma non riesco a capire cosa non va ecco il messaggio di errore che esce in fase di compilazione della lib.


"error: Error retrieving parent for item: No resource found that matches the given name 'android:Widget.Material.ActionButton'."

nel file xml
values-v21

ho letto di spostare il target a 23 ma non cambia niente l'errore si sposta su un'altro values...
mi sembra di girare intondo.

quello che ho fatto è stato importare il progetto in eclipse dal path del mio sdk dentro extras nello specifico questo path

sdk\extras\android\support\v7\appcompat

ho impostato il progetto come library ma come compila dal il messaggio che ho scritto sopra

qualche idea per risolvere ?

 


Offline BruceAndDevIT

  • Nuovo arrivato
  • *
  • Post: 12
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    lg l5
  • Sistema operativo:
    windows seven
Re:compilazione appcompaq-v7 con eclipse
« Risposta #1 il: 17 Dicembre 2015, 08:20:55 CET »
0
salve a tutti

ho un problema dopo aver lottato tantissimo con android studio ho deciso di tornare allo sviluppo con eclipse
quindi ho iniziato una fase porting da android studio vs eclipse di un mio progetto.

le caratteristiche di questo progetto sono

che usa materialdesign + lib appcompac design ...

ho letto vari articoli e post su stackoverflow in cui spiegava come compilare in eclipse la lib appcompav7

ho provato ma non riesco a capire cosa non va ecco il messaggio di errore che esce in fase di compilazione della lib.


"error: Error retrieving parent for item: No resource found that matches the given name 'android:Widget.Material.ActionButton'."

nel file xml
values-v21

ho letto di spostare il target a 23 ma non cambia niente l'errore si sposta su un'altro values...
mi sembra di girare intondo.

quello che ho fatto è stato importare il progetto in eclipse dal path del mio sdk dentro extras nello specifico questo path

sdk\extras\android\support\v7\appcompat

ho impostato il progetto come library ma come compila dal il messaggio che ho scritto sopra

qualche idea per risolvere ?

nessuno si è imbattuto in questo problema...

Offline iClaude

  • Utente normale
  • ***
  • Post: 183
  • Respect: +13
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy S5
  • Sistema operativo:
    Windows 10
Re:compilazione appcompaq-v7 con eclipse
« Risposta #2 il: 17 Dicembre 2015, 09:29:19 CET »
0
Ti consiglio di restare ad Android Studio:  é un IDE perfetto con miriadi di funzioni utili pensate in modo specifico x Android. Tra poco esce la versione 2.0 che si preannuncia molto interessante.
Spendi un paio di settimane x imparare bene come funziona e poi non torni più indietro.

Offline BruceAndDevIT

  • Nuovo arrivato
  • *
  • Post: 12
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    lg l5
  • Sistema operativo:
    windows seven
Re:compilazione appcompaq-v7 con eclipse
« Risposta #3 il: 17 Dicembre 2015, 09:34:48 CET »
0
Ti consiglio di restare ad Android Studio:  é un IDE perfetto con miriadi di funzioni utili pensate in modo specifico x Android. Tra poco esce la versione 2.0 che si preannuncia molto interessante.
Spendi un paio di settimane x imparare bene come funziona e poi non torni più indietro.

Prendo il consiglio è lo conservo ...
Ho notato comunque che ha parecchi bug Android Studio , ho deciso di ri-passare a eclipse pechè stavo spendendo il mio tempo non più a scrivere codice ma a risolvere
problemi di enviroment (tipo fastidiosi e continui problemi di heap che nn capisco a volte escono a volte si nascondono) non ultimo un problema (dopo aver fatto un update) di un "nullpointer exception"
non runtime ma in fase di compilazione ho tolto tutto e reinstallato ho scaricato lo zip e messo la 1.5 niente da fare non risolve il problema, anche io ho pensato di aspettare la 2.0 ma ne frattermpo volevo scrivere codice...

Quindi su Eclipse non sai darmi una mano ?