Autore Topic: Problemi con Android Studio 1.4  (Letto 516 volte)

Offline mauro.piccioli

  • Nuovo arrivato
  • *
  • Post: 13
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    S II
  • Sistema operativo:
    Windows Mac
Problemi con Android Studio 1.4
« il: 10 Ottobre 2015, 23:31:32 CEST »
0
Ho installato l'ultima versione la 1.4 e non riesco a combinare più nulla.
Non si possono utilizzare più molte librerie, per esempio org.apache.http, ho provato a compilare con un sdk inferiore al 23 e quelle funzioni sono tornate disponibili ma la compilazione si blocca perchè mi tornano una serie di errori legati alla libreria appcompat, insomma come si può compilare con un sdk precedente per poter continuare ad utilizzare vecchie funzioni senza aver complicazioni di errori legati alle nuove features di Studio 1.4?
Grazie 1000 a tutti.

Offline tonno16

  • Utente storico
  • *****
  • Post: 1197
  • Respect: +58
    • Mostra profilo
  • Dispositivo Android:
    moto g
  • Play Store ID:
    Diego Tonini
  • Sistema operativo:
    OpenSuse
Re:Problemi con Android Studio 1.4
« Risposta #1 il: 11 Ottobre 2015, 01:21:06 CEST »
0
Isa compile SDK 22. Comunque aggiungendo una direttiva su .gradle continua funzionare

Offline mauro.piccioli

  • Nuovo arrivato
  • *
  • Post: 13
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    S II
  • Sistema operativo:
    Windows Mac
Re:Problemi con Android Studio 1.4
« Risposta #2 il: 11 Ottobre 2015, 13:42:58 CEST »
0
Mi sai dire quale è la direttiva che devo mettere nel .gradle per poter compilare con un sdk precedente al 23?
Grazie 1000

Offline GabMarioPower

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 606
  • Respect: +152
    • Github
    • Google+
    • gabrielemariotti
    • GabMarioPower
    • Mostra profilo
  • Play Store ID:
    GAB+MARIO+DEV
  • Sistema operativo:
    Ubuntu 14.04 , Win 10
Re:Problemi con Android Studio 1.4
« Risposta #3 il: 01 Novembre 2015, 15:27:49 CET »
0
IL tuo problema non dipende da Android Studio.

org.apache.http è stato rimosso in Android 23.
Qui il documento ufficiale:
https://developer.android.com/about/versions/marshmallow/android-6.0-changes.html#behavior-apache-http-client

Offline tonno16

  • Utente storico
  • *****
  • Post: 1197
  • Respect: +58
    • Mostra profilo
  • Dispositivo Android:
    moto g
  • Play Store ID:
    Diego Tonini
  • Sistema operativo:
    OpenSuse
Re:Problemi con Android Studio 1.4
« Risposta #4 il: 01 Novembre 2015, 15:40:31 CET »
0
Io ho sempre usato asynkhttp come libreria. E mi accontento di quello che fa. Ovviamente usa quei oggetti. C'è un modo non massivo per risolvere il problema?