Autore Topic: problema GC_FOR_ALLOC  (Letto 413 volte)

Offline FabrizioMarquez

  • Nuovo arrivato
  • *
  • Post: 32
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    lg l70
  • Sistema operativo:
    Android
problema GC_FOR_ALLOC
« il: 23 Settembre 2015, 16:53:39 CEST »
0
Salve, ho creato un app semplice con qualche scaricamento dati da internet e riempimento di un db in uno SharedPreferences, ma ho problemi di allocazione di memoria ( GC_FOR_ALLOC  ) come posso fare a risolvere ?
grazie mille in anticipo a ognuno di voi che mi darà una mano !

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:problema GC_FOR_ALLOC
« Risposta #1 il: 23 Settembre 2015, 17:05:24 CEST »
0
quanta memoria stai usando?
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline FabrizioMarquez

  • Nuovo arrivato
  • *
  • Post: 32
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    lg l70
  • Sistema operativo:
    Android
Re:problema GC_FOR_ALLOC
« Risposta #2 il: 23 Settembre 2015, 18:41:08 CEST »
0
09-23 18:36:14.911    1471-1471/com.exampleApp D/dalvikvm﹕ GC_FOR_ALLOC freed 973K, 10% free 10393K/11548K, paused 28ms, total 28ms
09-23 18:36:15.101    1471-1471/com.exampleApp I/Choreographer﹕ Skipped 65 frames!  The application may be doing too much work on its main thread
il log mi da questo!
i miei 3 fragment nel PagerSlidingTabStrip ricevono i dati da un'activity iniziale che li scarica da un server, e inizializzano tutte le textView e Button. magari queste operazioni li devo gestire tramite Thread?!
Non saprei come procedere...
 il risultato è che il navigation D. si chiude scattosamente e il Fragment contente il PagerSlidingTabStrip  ci mette un po di tempo a inizializzarsi