Autore Topic: MinSDKVersion per applicazione con licensing  (Letto 922 volte)

Offline roccia80

  • Utente junior
  • **
  • Post: 89
  • Respect: 0
    • Mostra profilo
MinSDKVersion per applicazione con licensing
« il: 19 Dicembre 2010, 21:37:23 CET »
0
Buonasera ragazzi,

come da guida di android.com, uno dei requisiti da tenere in considerazione per applicare il controllo di licenza alla propria applicazione è quello di:
Citazione
An application can use the service only if the Android Market client is installed on its host device and the device is running Android 1.5 (API level 3) or higher
Di conseguenza, cosa devo impostare nel campo minSDKversion della mia applicazione? Al momento io inserisco 5, mentre nelle applicazioni gratuite (senza quindi controllo di licenza) metto 4 (con target 2.3). Cosa mi consigliate?

Grazie
Ciao
« Ultima modifica: 19 Dicembre 2010, 22:06:00 CET da JD, Reason: Corretto il tag off-topic in quote »

Offline JD

  • Amministratore
  • Utente storico
  • *****
  • Post: 1600
  • Respect: +232
    • leinardi
    • Mostra profilo
  • Dispositivo Android:
    LG Nexus 5
  • Sistema operativo:
    L'ultima Ubuntu
Re:MinSDKVersion per applicazione con licensing
« Risposta #1 il: 19 Dicembre 2010, 22:01:57 CET »
0
Non capisco bene in cosa consiste il tuo dubbio: il testo che hai quotato (anche se l'hai messo sotto tag off-topic :P) dice che per utilizzare il sistema di licenze serve almeno Android 1.5, quindi il minSDK deve essere almeno 3.

Ricapitolando, per le applicazioni che utilizzano il sistema di licenza di Android utilizza un minSDK >= 3 (cioè 3, 4, 5, 6, 7, 8, 9).
È stata trovata una soluzione al tuo problema?
Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato ;).
E se hai aperto tu il thread marcalo come risolto cliccando !

Offline roccia80

  • Utente junior
  • **
  • Post: 89
  • Respect: 0
    • Mostra profilo
Re:MinSDKVersion per applicazione con licensing
« Risposta #2 il: 19 Dicembre 2010, 22:04:12 CET »
0
Non capisco bene in cosa consiste il tuo dubbio: il testo che hai quotato (anche se l'hai messo sotto tag off-topic :P) dice che per utilizzare il sistema di licenze serve almeno Android 1.5, quindi il minSDK deve essere almeno 3.

Ricapitolando, per le applicazioni che utilizzano il sistema di licenza di Android utilizza un minSDK >= 3 (cioè 3, 4, 5, 6, 7, 8, 9).

Grazie! Era proprio la risposta che mi serviva. Perdona il testo quotato male...
Ciao