Autore Topic: Icona Applicazione ActionBar  (Letto 275 volte)

Offline Friz02

  • Utente junior
  • **
  • Post: 104
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    s3 neo Samsung
  • Sistema operativo:
    windows 7
Icona Applicazione ActionBar
« il: 06 Luglio 2015, 19:38:21 CEST »
0
Ciao a tutti,
durante l'aggiornamento di un App (per introdurre i fragment), tra le varie cose ho anche aggiornando la libreria appcompat-v7 alla versione 22.2.0; tutto ok tranne l'icona dell'applicazione sull'ActionBar che è sparita. Sono due giorni che tento di sistemare la cosa ma niente, qualcuno ha avuto lo stesso problema?

Offline Bo

  • Utente junior
  • **
  • Post: 68
  • Respect: +3
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy Note 3
  • Sistema operativo:
    windows 10
Re:Icona Applicazione ActionBar
« Risposta #1 il: 06 Luglio 2015, 19:59:06 CEST »
0
Hai provato con
Codice (Java): [Seleziona]
getSupportActionBar().setDisplayShowHomeEnabled(true);
        getSupportActionBar().setIcon(R.drawable.icona);

Offline Friz02

  • Utente junior
  • **
  • Post: 104
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    s3 neo Samsung
  • Sistema operativo:
    windows 7
Re:Icona Applicazione ActionBar
« Risposta #2 il: 06 Luglio 2015, 20:14:15 CEST »
0
Gia provato ma non funziona.....

Offline Bo

  • Utente junior
  • **
  • Post: 68
  • Respect: +3
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy Note 3
  • Sistema operativo:
    windows 10
Re:Icona Applicazione ActionBar
« Risposta #3 il: 06 Luglio 2015, 20:25:25 CEST »
0
Ora dovrebbe andare
Codice (Java): [Seleziona]
getSupportActionBar().setDisplayShowHomeEnabled(true);
 getSupportActionBar().setLogo(R.drawable.ic_launcher);
 getSupportActionBar().setDisplayUseLogoEnabled(true);

Offline Friz02

  • Utente junior
  • **
  • Post: 104
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    s3 neo Samsung
  • Sistema operativo:
    windows 7
Re:Icona Applicazione ActionBar
« Risposta #4 il: 06 Luglio 2015, 23:14:25 CEST »
0
Ottimo....ora funziona...grazie!