Autore Topic: http , css  (Letto 472 volte)

Offline _SC_

  • Nuovo arrivato
  • *
  • Post: 20
  • Respect: 0
    • Mostra profilo
http , css
« il: 18 Dicembre 2010, 15:58:09 CET »
0
Ho realizzato una activity con WebView, dove visualizzo una pagina http collegata ad un css, che a sua volta richiama immagini , stili ecc.
In soldoni non visualizzo la stessa cosa che visualizzo col browser. In Particolare non funziona il background fisso, ne i colori sono resi come sul browser:
Codice (CSS): [Seleziona]
body
{
background-image:url('fascia 1.jpg');
background-repeat:no-repeat;
background-attachment:fixed;
background-position: right top;
background-color: #E7E7E7;
}

p
{text-align: justify; text-indent: 12px;}

Il colore lo prende e lo mette grigio, ma è diverso da quello del browser e l'attributo fixed viene ignorato.

Prima di rimettermi a cambiare la view, senza usare la WebView, qualcuno ha qualche suggerimento/idea?
Grazie di tutto.

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:http , css
« Risposta #1 il: 19 Dicembre 2010, 12:55:06 CET »
0
Ho realizzato una activity con WebView, dove visualizzo una pagina http collegata ad un css, che a sua volta richiama immagini , stili ecc.
In soldoni non visualizzo la stessa cosa che visualizzo col browser. In Particolare non funziona il background fisso, ne i colori sono resi come sul browser:
Il colore lo prende e lo mette grigio, ma è diverso da quello del browser e l'attributo fixed viene ignorato.
Prima di rimettermi a cambiare la view, senza usare la WebView, qualcuno ha qualche suggerimento/idea?
Grazie di tutto.

Ho spostato (almeno per ora) in Altri Problemi perchè dal titolo e dal codice sembra più un problema di CSS. Senza qualche screenshot è difficile rendersi conto della natura effettiva del problema, se riesci a metterli tutti e due (del telefono e del pc) sarebbe perfetto.

Per quanto riguarda i problemi specifici, quello del background fixed potrebbe essere un mancato supporto del browser che stai usando alla proprietà CSS in questione. Prova a mettere sul telefono un altro browser per prova.

Il discorso del colore potrebbe essere una modalità con meno colori, tipo se stai usando un terminale limitato in tal senso. Per questo problema specifico, eviterei di fare pagine in cui i colori devono essere perfetti (per intendersi, se devi accostare uno sfondo e una bitmap, usa la trasparenza sulla bitmap e non dare alla bitmap lo stesso sfondo della pagina).
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store