Autore Topic: Problema con gradle dopo aggiornamento libreria  (Letto 464 volte)

Offline felasandroid

  • Utente normale
  • ***
  • Post: 345
  • Respect: +10
    • Github
    • balduzziantonio
    • balduzziantonio.unifi
    • Mostra profilo
  • Dispositivo Android:
    Huawei P8 Lite
  • Play Store ID:
    FelasTech
  • Sistema operativo:
    Windows 10
Problema con gradle dopo aggiornamento libreria
« il: 09 Aprile 2015, 18:16:19 CEST »
0
Salve

ho aggiornato la libreria MaterialDialogs con:     compile 'com.afollestad:material-dialogs:0.7.1.0'

solo che dopo questo aggiornamento se provo a fare il Run dell'app ottengo:

Codice: [Seleziona]
Error:Execution failed for task ':app:dexDebug'.
> com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command '/usr/lib/jvm/java-7-oracle/bin/java'' finished with non-zero exit value 2

il mio file gradle è questo:

Codice: [Seleziona]
android {

compileSdkVersion 22
buildToolsVersion "22.0.1"
defaultConfig {
    applicationId "package.com"
    minSdkVersion 15
    targetSdkVersion 22
    versionCode 1
    versionName "Alpha 1"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
    }
}
packagingOptions {
    exclude 'META-INF/NOTICE.txt'
    exclude 'META-INF/LICENSE.txt'
}

}

repositories {
flatDir {
dirs 'libs'
}

}

dependencies {
//Core
compile fileTree(dir: 'libs', include: ['*.jar'])
compile files('libs/khandroid-httpclient-4.2.3.jar')
compile files('libs/YouTubeAndroidPlayerApi.jar')
compile files('libs/mpandroidchartlibrary-1-7-4.jar')
compile files('libs/additionnal.jar')
compile files('libs/mail.jar')
compile files('libs/activation.jar')
compile project(':library-viewpagerindicator')
compile(name: 'com.doomonafireball.betterpickers', ext: 'aar') {
exclude module: 'support-v4'
}
compile 'com.github.gabrielemariotti.cards:cardslib-core:2.0.1'
compile 'com.github.gabrielemariotti.cards:cardslib-recyclerview:2.0.1'

compile 'de.hdodenhof:circleimageview:1.2.1'
compile 'com.mcxiaoke.volley:library:1.0.+'
compile 'com.google.code.gson:gson:2.3.+'
compile 'org.apache.commons:commons-lang3:3.3.2'
compile 'com.amulyakhare:com.amulyakhare.textdrawable:1.0.1'
compile 'com.jakewharton:butterknife:6.1.0'
compile 'com.android.support:appcompat-v7:22.0.0'
compile 'com.android.support:support-v4:22.0.0'
compile 'com.android.support:recyclerview-v7:21.0.3'
compile 'com.afollestad:material-dialogs:0.7.1.0'
compile 'com.makeramen:roundedimageview:2.0.0'
compile 'joda-time:joda-time:2.1'
compile 'de.greenrobot:eventbus:2.4.0'
compile 'com.google.android.gms:play-services:6.5.87'
compile 'org.osmdroid:osmdroid-android:4.3'
compile 'org.slf4j:slf4j-simple:1.6.1'
}


Il creatore della libreria mi ha detto:

You need the jcenter() repository. Android Studio uses it by default but it looks like you override repositories.

Ma io ho la configurazione standard..
« Ultima modifica: 09 Aprile 2015, 18:30:01 CEST da felasandroid »