Autore Topic: Lollipop & debug  (Letto 767 volte)

Offline wlf

  • Utente normale
  • ***
  • Post: 335
  • Respect: +8
    • Mostra profilo
  • Dispositivo Android:
    Xperia
Lollipop & debug
« il: 02 Aprile 2015, 09:25:06 CEST »
0
Salve ragazzi, sono a chiedervi se c'è qualcuno che sta utilizzando uno smartphone con Lollipop con il cavetto USB per effettuare il debug di qualche App.
Io ieri ho messo Lollipop su un LG G2 brandizzato, visto che era ufficialmente disponibile, e da allora non c'è più verso di far funzionare il debug! :(

La voce "Opzioni dello sviluppatore" mi è rimasta attiva, ma sembra "fregarsene" anche se in alto nella status bar vedo sia il simboletto dell'USB che quello del debug con lo scarafaggio. :(

Attaccando un altro smartphone sulla stessa porta USB il debug continua a funzionare, quindi escluderei che sia dovuto al PC.

Qualcun altro ha provato a testare un LG G2 con Lollipop?

Offline Nicola_D

  • Utente storico
  • *****
  • Post: 2479
  • SBAGLIATO!
  • Respect: +323
    • Github
    • Google+
    • nicoladorigatti
    • Mostra profilo
  • Dispositivo Android:
    Nexus 6p, Nexus 4, Nexus S, Nexus 7(2012)
  • Sistema operativo:
    Windows 7
Re:Lollipop & debug
« Risposta #1 il: 02 Aprile 2015, 10:42:49 CEST »
0
nelle impo svliuppatore del device c'è una voce per elimnare i device collegati "Revoca Autorizzazione debug USB".
Scollega il telefono, seleziona l'opzione e dagli ok, dopodichè ricollega il telefono, dovrebbe funzionare
IMPORTANTE:NON RISPONDO A PROBLEMI VIA MESSAGGIO PRIVATO
LOGCAT: Non sai cos'è? -> Android Debug Bridge | Android Developers
               Dov'è in Eclipse? -> Window -> Open Prospective -> DDMS e guarda in basso!
[Obbligatorio] Logcat, questo sconosciuto! (Gruppo AndDev.it LOGTFO) - Android Developers Italia

Offline wlf

  • Utente normale
  • ***
  • Post: 335
  • Respect: +8
    • Mostra profilo
  • Dispositivo Android:
    Xperia
Re:Lollipop & debug
« Risposta #2 il: 02 Aprile 2015, 11:08:32 CEST »
0
nelle impo svliuppatore del device c'è una voce per elimnare i device collegati "Revoca Autorizzazione debug USB".
Scollega il telefono, seleziona l'opzione e dagli ok, dopodichè ricollega il telefono, dovrebbe funzionare

Avevo provato infruttuosamente; ho risolto passando da MTP a PTP nelle impostazioni "Connessione USB PC". Ma sospetto che sia dovuto ai driver (vecchi?) caricati su win 8.1. Per ora l'ho "pezzata" così, ma appena ho un po' di tempo proverò a reinstallare in driver per controllare se si rimette a funzionare anche in MTP (che preferisco). ;)