Autore Topic: Strano comportamento con la pubblicita'  (Letto 430 volte)

Offline oberdank

  • Utente normale
  • ***
  • Post: 287
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy Core LTE
  • Play Store ID:
    BuzzOne
  • Sistema operativo:
    Windows 8.1
Strano comportamento con la pubblicita'
« il: 25 Marzo 2015, 12:32:28 CET »
Ho notato un comportamento "strano" della mia app:
ho inserito un banner pubblicitario

        mAdView = (AdView) findViewById(R.id.adView);
        AdRequest adRequest = new AdRequest.Builder()
                .build();
        mAdView.loadAd(adRequest);

e il banner appare sia sull'emulatore che sul cellulare reale, quando metto gli .addTestDevice() cosi'

        mAdView = (AdView) findViewById(R.id.adView);
        AdRequest adRequest = new AdRequest.Builder()
                .addTestDevice(AdRequest.DEVICE_ID_EMULATOR)
                .addTestDevice("B3EEABB8EE11C2BE770B684D95219ECB")
                .build();
        mAdView.loadAd(adRequest);

sull'emulatore appare correttamente il banner di prova (NON la pubblicita' vera e propia), mentre sul cellulare
CONTINUA ad apparire la pubblicita' vera e propia (NON il banner di prova), COME MAI?

Offline eagledeveloper

  • Translate Team
  • Utente senior
  • ****
  • Post: 516
    • Google+
    • 347516210
    • dark_pinz
    • @WandDStudios
    • Mostra profilo
    • W&D Studios
  • Dispositivo Android:
    HTC One X e HTC One
  • Play Store ID:
    W%26D+Studios
  • Sistema operativo:
    Ubuntu / Windows 7
Re:Strano comportamento con la pubblicita'
« Risposta #1 il: 25 Marzo 2015, 15:18:02 CET »
Sei sicuro che il tuo device sia identificato da B3EEABB8EE11C2BE770B684D95219ECB?
I numeri contano molto di più del seme.

Offline oberdank

  • Utente normale
  • ***
  • Post: 287
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy Core LTE
  • Play Store ID:
    BuzzOne
  • Sistema operativo:
    Windows 8.1
Re:Strano comportamento con la pubblicita'
« Risposta #2 il: 25 Marzo 2015, 15:24:21 CET »
Si, sono sicuro.
Ripeto che sull'emulatore appare correttamente il banner di prova.