Sondaggio

Come risolvo il problema?

una spiegazione dettagliata scritta
0 (0%)
con delle immagini...
0 (0%)

Totale votanti: 0

Autore Topic: Problema con l'emulatore  (Letto 652 volte)

Offline EonHat

  • Nuovo arrivato
  • *
  • Post: 5
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    GT-I9195
  • Sistema operativo:
    Windows 8
Problema con l'emulatore
« il: 31 Gennaio 2015, 23:49:50 CET »
0
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!

mi segnala questo quando cerco di emulare solo una stringa ovver "Hello World"
PS: ho scaricato già scaricato Intel x86 emulator Accelerator(HAXM installer) che si trova in ---> Extra.

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Problema con l'emulatore
« Risposta #1 il: 01 Febbraio 2015, 08:22:24 CET »
0
Non so se ti può aiutare, ma l'HAXM che hai scaricato, io ho dovuto installarlo "a mano". Prova ad andare nella cartellka EXTRA e fare doppio-clic sull'eseguibile.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline EonHat

  • Nuovo arrivato
  • *
  • Post: 5
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    GT-I9195
  • Sistema operativo:
    Windows 8
Re:Problema con l'emulatore
« Risposta #2 il: 01 Febbraio 2015, 10:28:05 CET »
0
ma dici nel SDK Manager perchè sennò me lo elimina e basta.

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Problema con l'emulatore
« Risposta #3 il: 01 Febbraio 2015, 15:24:21 CET »
0
ma dici nel SDK Manager perchè sennò me lo elimina e basta.

Apri il folder dove ti è stato scaricato il file di installazione di HAXM e lancialo per installarlo. Io ho dovuto fare così.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline Brontomania

  • Nuovo arrivato
  • *
  • Post: 32
  • Dinosauro di lanetta
  • Respect: +5
    • Github
    • Google+
    • @Brontomania
    • Mostra profilo
  • Dispositivo Android:
    HTC One, Nexus 7, Nexus S
  • Sistema operativo:
    Windows 10
Re:Problema con l'emulatore
« Risposta #4 il: 01 Febbraio 2015, 19:01:44 CET »
0
Confermo Bradipao: qualsiasi aggiornamento dell'haxm ho dovuto lanciarlo a mano. Trovi l'eseguibile da lanciare nella sdk, nella cartella extras /Intel, mi pare.

TTalk on HTC1


Offline EonHat

  • Nuovo arrivato
  • *
  • Post: 5
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    GT-I9195
  • Sistema operativo:
    Windows 8
Re:Problema con l\'emulatore
« Risposta #5 il: 02 Febbraio 2015, 16:54:54 CET »
0
grazie... ma mentre stavo installando mi ha riscontrato un'altro problema ovvero Intel Virtualization Technology (VT-x) is not turned on. come lo risolvo?

Post unito: 02 Febbraio 2015, 17:50:10 CET
anzi ho risolto solo che mi appare l'emulatore con solo scritta "Android" invece che la stringa "HelloWorld"....
« Ultima modifica: 02 Febbraio 2015, 17:50:10 CET da EonHat, Reason: Merged DoublePost »