Autore Topic: Layout su Emulatore e poi su real device  (Letto 332 volte)

Offline prograf2

  • Nuovo arrivato
  • *
  • Post: 2
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Huawei y600
  • Sistema operativo:
    Windows 7 Ultimate
Layout su Emulatore e poi su real device
« il: 26 Dicembre 2014, 10:48:40 CET »
0
Ciao a tutti e Tanti Auguri di Buone Feste....

E' da parecchi che tento di definire un layout in Android Studio 1.0.2 dove utilizzo i dp per posizionare i vari button
e dove eseguo il test su emulatore ... Ebbene su emulatore e' tutto corretto ma poi quanto eseguo un test sul mio
cell (Huawei Y600  480x854 px diagonale da 5.0 pollici) i button sono spostati .....
Come devo fare ????

Offline tonno16

  • Utente storico
  • *****
  • Post: 1228
  • Respect: +59
    • Mostra profilo
  • Dispositivo Android:
    moto g
  • Play Store ID:
    Diego Tonini
  • Sistema operativo:
    OpenSuse
Re:Layout su Emulatore e poi su real device
« Risposta #1 il: 26 Dicembre 2014, 14:22:52 CET »
0
Ovvio. Nel emulatore puoi configurare uno schermo s tuo piacimento. Addirittura nel layout mentre setti il tuo xml puoi selezionare un dispositivo.

Offline prograf2

  • Nuovo arrivato
  • *
  • Post: 2
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Huawei y600
  • Sistema operativo:
    Windows 7 Ultimate
Re:Layout su Emulatore e poi su real device
« Risposta #2 il: 26 Dicembre 2014, 15:29:19 CET »
0
Grazie per la risposta ..... ma e' ovvio che :

         1 - Ho creato AVD emulatore con le caratteristiche del real device (risoluzione e ppi)
         2 - Durante la definizione del Layout , linguetta 'design' ... ho selezionato l'emulatore corretto.
         3 - Penso che qualche problema possa darmelo il 'RelativeLayout'.


Offline tonno16

  • Utente storico
  • *****
  • Post: 1228
  • Respect: +59
    • Mostra profilo
  • Dispositivo Android:
    moto g
  • Play Store ID:
    Diego Tonini
  • Sistema operativo:
    OpenSuse
Re:Layout su Emulatore e poi su real device
« Risposta #3 il: 26 Dicembre 2014, 16:39:28 CET »
0
Penso di no. Mai avuto problemi io