Autore Topic: Errore appcompat_v7  (Letto 3636 volte)

Offline Neoxxx

  • Translate Team
  • Utente junior
  • **
  • Post: 114
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    HTC Desire
  • Sistema operativo:
    Windows 7
Errore appcompat_v7
« il: 06 Novembre 2014, 18:04:00 CET »
0
Ciao a tutti, ho un problema che non riesco a risolvere...appena creo un nuovo progetto mi escono questi errori:

Codice: [Seleziona]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v11\themes_base.xml:359: error: Error: No resource found that matches the given name: attr 'android:actionModeShareDrawable'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v14\themes_base.xml:53: error: Error: No resource found that matches the given name: attr 'android:actionModeShareDrawable'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:202: error: Error retrieving parent for item: No resource found that matches the given name 'android:ThemeOverlay.Material'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:212: error: Error retrieving parent for item: No resource found that matches the given name 'android:ThemeOverlay.Material.Light'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:205: error: Error retrieving parent for item: No resource found that matches the given name 'android:ThemeOverlay.Material.Dark'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:219: error: Error retrieving parent for item: No resource found that matches the given name 'android:ThemeOverlay.Material.ActionBar'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:223: error: Error retrieving parent for item: No resource found that matches the given name 'android:ThemeOverlay.Material.Dark.ActionBar'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:81: error: Error: No resource found that matches the given name: attr 'android:colorAccent'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:83: error: Error: No resource found that matches the given name: attr 'android:colorControlActivated'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:84: error: Error: No resource found that matches the given name: attr 'android:colorControlHighlight'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:82: error: Error: No resource found that matches the given name: attr 'android:colorControlNormal'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:79: error: Error: No resource found that matches the given name: attr 'android:colorPrimary'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:80: error: Error: No resource found that matches the given name: attr 'android:colorPrimaryDark'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:118: error: Error: No resource found that matches the given name: attr 'android:colorAccent'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:120: error: Error: No resource found that matches the given name: attr 'android:colorControlActivated'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:121: error: Error: No resource found that matches the given name: attr 'android:colorControlHighlight'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:119: error: Error: No resource found that matches the given name: attr 'android:colorControlNormal'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:116: error: Error: No resource found that matches the given name: attr 'android:colorPrimary'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:117: error: Error: No resource found that matches the given name: attr 'android:colorPrimaryDark'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:155: error: Error: No resource found that matches the given name: attr 'android:colorAccent'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:157: error: Error: No resource found that matches the given name: attr 'android:colorControlActivated'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:158: error: Error: No resource found that matches the given name: attr 'android:colorControlHighlight'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:156: error: Error: No resource found that matches the given name: attr 'android:colorControlNormal'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:153: error: Error: No resource found that matches the given name: attr 'android:colorPrimary'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:154: error: Error: No resource found that matches the given name: attr 'android:colorPrimaryDark'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:192: error: Error: No resource found that matches the given name: attr 'android:colorAccent'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:194: error: Error: No resource found that matches the given name: attr 'android:colorControlActivated'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:195: error: Error: No resource found that matches the given name: attr 'android:colorControlHighlight'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:193: error: Error: No resource found that matches the given name: attr 'android:colorControlNormal'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:190: error: Error: No resource found that matches the given name: attr 'android:colorPrimary'.
[2014-11-06 17:58:35 - QRCodeScanner]
[2014-11-06 17:58:35 - QRCodeScanner] C:\Users\Gabriele\workspace\appcompat_v7\res\values-v21\themes_base.xml:191: error: Error: No resource found that matches the given name: attr 'android:colorPrimaryDark'.
[2014-11-06 17:58:35 - QRCodeScanner]

Immagino ci voglia l'SDK di Android 5 ma non lo voglio perchè mi da qualche errrore. Io il progetto l'ho creato per la 4.4.2 quindi non capisco perchè voglia le API21

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Errore appcompat_v7
« Risposta #1 il: 06 Novembre 2014, 18:19:16 CET »
0
Non lo so per certo, ma ho come l'impressione che la appcompat_v7 abbia bisogno delle api21.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline Neoxxx

  • Translate Team
  • Utente junior
  • **
  • Post: 114
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    HTC Desire
  • Sistema operativo:
    Windows 7
Re:Errore appcompat_v7
« Risposta #2 il: 06 Novembre 2014, 18:20:52 CET »
0
Ma app_compat_v7 serve per forza?
Ho provato anche a cancellare  la cartella values-v21 e basta ma l'errore rimane

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Errore appcompat_v7
« Risposta #3 il: 06 Novembre 2014, 18:37:13 CET »
0
Ma app_compat_v7 serve per forza?

No di certo, serve se vuoi che elementi specifici introdotti nelle ultime versioni di android, siano usabili anche dalle versioni precedenti. Dipende quindi dal MINSDK che hai scelto, dal TARGETSDK che hai scelto e dalle classi/funzioni che vuoi usare.

Nel sito ufficiale c'è scritto in dettaglio cosa ciascuna appcompat supporta.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline Neoxxx

  • Translate Team
  • Utente junior
  • **
  • Post: 114
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    HTC Desire
  • Sistema operativo:
    Windows 7
Re:Errore appcompat_v7
« Risposta #4 il: 06 Novembre 2014, 18:54:27 CET »
0
No perchè io non ho ben caqpito a cosa serve...appena creo anche un HelloWorld mi crea appcompact_7

La cosa che non capisco è perchè se gli do come MINSDK e TARGET le API 19 mi va a chiedere le 21, è un controsenso.

Offline Illogica

  • Nuovo arrivato
  • *
  • Post: 32
  • Respect: +4
    • Google+
    • Mostra profilo
    • Illogica Software
  • Dispositivo Android:
    Caterpillar B15Q / Asus Padfone Infinity / Htc Pyramid / Samsung Galaxy *
  • Play Store ID:
    Illogica Software
  • Sistema operativo:
    Ubuntu 14.04
Re:Errore appcompat_v7
« Risposta #5 il: 06 Novembre 2014, 19:14:13 CET »
0
Prova a postare il tuo build.gradle più interno, quello a livello di modulo (quello più pieno di roba)

Offline Neoxxx

  • Translate Team
  • Utente junior
  • **
  • Post: 114
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    HTC Desire
  • Sistema operativo:
    Windows 7
Re:Errore appcompat_v7
« Risposta #6 il: 07 Novembre 2014, 11:29:15 CET »
0
Utilizzo eclipse...ma ho appena installato tutto... Eclipse + adt e scaricato SDK 19,20,21...mi usciva qualche errore con la L preview allora ho tolto le Api 21 e adesso alla semplice creazione di un nuovo progetto mi esce questo errore

Offline Nicola_D

  • Utente storico
  • *****
  • Post: 2479
  • SBAGLIATO!
  • Respect: +323
    • Github
    • Google+
    • nicoladorigatti
    • Mostra profilo
  • Dispositivo Android:
    Nexus 6p, Nexus 4, Nexus S, Nexus 7(2012)
  • Sistema operativo:
    Windows 7
Re:Errore appcompat_v7
« Risposta #7 il: 07 Novembre 2014, 12:10:29 CET »
0
allora, se hai l'sdk21 non dovresti avere problemi,
ma ad ogni modo, non è il MINSDK il problema ma il target e il buildsdk.
controlla che non siano a 21!
IMPORTANTE:NON RISPONDO A PROBLEMI VIA MESSAGGIO PRIVATO
LOGCAT: Non sai cos'è? -> Android Debug Bridge | Android Developers
               Dov'è in Eclipse? -> Window -> Open Prospective -> DDMS e guarda in basso!
[Obbligatorio] Logcat, questo sconosciuto! (Gruppo AndDev.it LOGTFO) - Android Developers Italia

Offline Neoxxx

  • Translate Team
  • Utente junior
  • **
  • Post: 114
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    HTC Desire
  • Sistema operativo:
    Windows 7
Re:Errore appcompat_v7
« Risposta #8 il: 07 Novembre 2014, 12:27:34 CET »
0
No il 21 lo avevo ma mi dava un errore riguardo parsesdk e cercando ho letto che erano queste api...visto che non mi interessa android 5 le ho tolte e di conseguenza ho messo come min e target SDK le 20...e nel progetto sono impostate giuste...é il maledetto appcompat che da errore

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Errore appcompat_v7
« Risposta #9 il: 07 Novembre 2014, 12:43:13 CET »
0
No il 21 lo avevo ma mi dava un errore riguardo parsesdk e cercando ho letto che erano queste api...visto che non mi interessa android 5 le ho tolte e di conseguenza ho messo come min e target SDK le 20...e nel progetto sono impostate giuste...é il maledetto appcompat che da errore

Le 20 le eviterei. Usa le 19, che sono quelle di KitKat.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline Neoxxx

  • Translate Team
  • Utente junior
  • **
  • Post: 114
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    HTC Desire
  • Sistema operativo:
    Windows 7
Re:Errore appcompat_v7
« Risposta #10 il: 07 Novembre 2014, 13:12:02 CET »
0
OK allora le tolgo...se non riesco a risolvere dovrò installare le 21 e mi terrò gli altri errori...oppure cancello il progetto appcompat e tengo solo helllworld

Offline BlackJad

  • Utente junior
  • **
  • Post: 59
  • Respect: +6
    • Google+
    • michele-ziparo/4/825/a99/
    • blackjad82
    • Mostra profilo
    • Datawit Systems
  • Dispositivo Android:
    Samsung Galaxy S3
  • Play Store ID:
    Michele Ziparo
  • Sistema operativo:
    Windows 8.1
Re:Errore appcompat_v7
« Risposta #11 il: 08 Novembre 2014, 13:01:52 CET »
0
OK allora le tolgo...se non riesco a risolvere dovrò installare le 21 e mi terrò gli altri errori...oppure cancello il progetto appcompat e tengo solo helllworld
Anche a me è capitato lo stesso errore in Android Studio, il problema si risolve indicando come CompileSDK la versione 21, e poi BuildTools 21.1.0

Offline Neoxxx

  • Translate Team
  • Utente junior
  • **
  • Post: 114
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    HTC Desire
  • Sistema operativo:
    Windows 7
Re:Errore appcompat_v7
« Risposta #12 il: 08 Novembre 2014, 17:30:23 CET »
0
Ho installato le API 21 e il problema si è risolto, appare ogni tanto l'errore parsesdk ma non si può avere tutto

Offline dellaz

  • Nuovo arrivato
  • *
  • Post: 42
  • Respect: +2
    • Mostra profilo
  • Dispositivo Android:
    Nexus 7 (2012), Samsung s6 Edge
  • Sistema operativo:
    Win 8.1, Ubuntu 16.10, Mac OS X 10.10 (Yosemite)
Re:Errore appcompat_v7
« Risposta #13 il: 08 Novembre 2014, 18:58:03 CET »
0
Ho provato anche a cancellare  la cartella values-v21 e basta ma l'errore rimane
Eliminare semplicemente quella cartella non basta, perché dalla revisione 21 in poi, la libreria appcompat-v7 introduce il material design (quindi è necessario che il target sia android 5.0). L'unica cosa che puoi fare è installare l'sdk di android 5.0 oppure (se lavori con android studio) ti scarichi la "android support repository" ed utilizzi una versione vecchia (es: la 20.xy, che si basa su android 4.4)
LogCat is the way!
Hai trovato utile una risposta? Clicca su

Offline GabMarioPower

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 606
  • Respect: +152
    • Github
    • Google+
    • gabrielemariotti
    • GabMarioPower
    • Mostra profilo
  • Play Store ID:
    GAB+MARIO+DEV
  • Sistema operativo:
    Ubuntu 14.04 , Win 10
Re:Errore appcompat_v7
« Risposta #14 il: 09 Novembre 2014, 13:02:35 CET »
0
Non credo che sia un problema di target o minsdk.
Secondo me , semplicemente tu stai usando la app compat library a versione 21 che ha quelle dipendenze.

Innanzitutto non confondere TARGET con la versione che utilizzi per compilare (sono due cose completamente diverse).
La versione che utilizzi per compilare è quella che selezioni con Proprietà->Tab Android su Eclipse.

Se non vuoi usare la app_compat a versione 21, nel tuo sdk hai sicuramente quella a versione 19 o 20.

Ps. E' tempo di passare ad Android Studio.