Autore Topic: Android-support-v7-appcompat  (Letto 457 volte)

Offline dellaz

  • Nuovo arrivato
  • *
  • Post: 42
  • Respect: +2
    • Mostra profilo
  • Dispositivo Android:
    Nexus 7 (2012), Samsung s6 Edge
  • Sistema operativo:
    Win 8.1, Ubuntu 16.10, Mac OS X 10.10 (Yosemite)
Android-support-v7-appcompat
« il: 18 Ottobre 2014, 18:54:19 CEST »
0
Ciao a tutti, ho accidentalmente aggiornato la libreria di supporto alla revisione 21, cosa che mi impedisce di utilizzare il tema "Holo" nelle mie app (posso usare solo il tema "material", quello di Lollipop).
Chiedo a qualche anima pia se mi potrebbe gentilmente inviare (per allegato, PM o via mail) la versione precedente di questa libreria, ovvero la REVISION 20!
Grazie in anticipo ;)
LogCat is the way!
Hai trovato utile una risposta? Clicca su

Offline GabMarioPower

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 606
  • Respect: +152
    • Github
    • Google+
    • gabrielemariotti
    • GabMarioPower
    • Mostra profilo
  • Play Store ID:
    GAB+MARIO+DEV
  • Sistema operativo:
    Ubuntu 14.04 , Win 10
Re:Android-support-v7-appcompat
« Risposta #1 il: 19 Ottobre 2014, 16:36:06 CEST »
0
Dentro la cartella dell'sdk trovi tutte le versioni della support, non solo l'ultima.
Path: sdk/extras/android/m2repository/com/android/support/appcompat-v7

Se utilizzi gradle è sufficiente poi cambiare la dipendenza sul build.gradle (ma immagino che usi Eclipse).



Offline dellaz

  • Nuovo arrivato
  • *
  • Post: 42
  • Respect: +2
    • Mostra profilo
  • Dispositivo Android:
    Nexus 7 (2012), Samsung s6 Edge
  • Sistema operativo:
    Win 8.1, Ubuntu 16.10, Mac OS X 10.10 (Yosemite)
Re:Android-support-v7-appcompat
« Risposta #2 il: 19 Ottobre 2014, 16:52:31 CEST »
0
Si esatto, ho eclipse.

Immagino che per avere la cartella "m2repository" serva aver scaricato l' "Android Support Repository", cosa che non ho! Provvedo a scaricarlo e vedo di ricavare la libreria! Intanto grazie ;)
LogCat is the way!
Hai trovato utile una risposta? Clicca su

Offline GabMarioPower

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 606
  • Respect: +152
    • Github
    • Google+
    • gabrielemariotti
    • GabMarioPower
    • Mostra profilo
  • Play Store ID:
    GAB+MARIO+DEV
  • Sistema operativo:
    Ubuntu 14.04 , Win 10
Re:Android-support-v7-appcompat
« Risposta #3 il: 20 Ottobre 2014, 09:57:41 CEST »
0
Si esatto, ho eclipse.

Immagino che per avere la cartella "m2repository" serva aver scaricato l' "Android Support Repository", cosa che non ho! Provvedo a scaricarlo e vedo di ricavare la libreria! Intanto grazie ;)

Si devi aggiornare l'SDK Manager