Autore Topic: appcompat_v7  (Letto 465 volte)

Offline astro87

  • Nuovo arrivato
  • *
  • Post: 21
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    motorola moto g
  • Sistema operativo:
    windows 7
appcompat_v7
« il: 01 Agosto 2014, 15:13:20 CEST »
0
Salve a tutti, premetto che sono novizio di android ed è la prima volta che scrivo in questo forum e prima di farlo ho cercato in lungo e largo una soluzione ma niente da fare.Il problema è il seguente:
dopo aver scaricato eclipse ed sdk ed aver installato l'adt, al momento della creazione di un progetto si crea una nuova cartella appcompat_v7 ( credo per poter utilizzare le nuove funzionalità dall'api level 14 in su) ma con un punto esclamativo rosso e lo stesso vale sulla cartella del progetto da me creato. Vi allego alcune immagini.





Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:appcompat_v7
« Risposta #1 il: 01 Agosto 2014, 17:00:45 CEST »
0
Magari mi sbaglio, ma mettere minsdk=froyo, targetsdk=L-preview e compilewith=KitkatWear è una combinazione esplosiva.

Per andare tranquillo crea l'app mettendo minsdk=14, targetsdk=19, compilewith=19. Ovviamente scaricando API19.

Evita assolutamente L-preview e Wear a meno di non sapere esattamente cosa stai facendo.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline astro87

  • Nuovo arrivato
  • *
  • Post: 21
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    motorola moto g
  • Sistema operativo:
    windows 7
Re:appcompat_v7
« Risposta #2 il: 01 Agosto 2014, 17:07:55 CEST »
0
Perfetto. Ci provo e ti aggiorno. Però vorrei farti una domanda: con minsdk=froyo vuol dire che l'applicazione che intendo creare necessita di almeno un sistema 2.2 giusto?mentre con target imposto il sistema su cui l'applicazione viene implementata. Non ho capito il significato del campo compile, ho provato ad impostare froyo anche lì ma non mi permette di andare avanti e quindi sono obbligato a mettere wear come mai?

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:appcompat_v7
« Risposta #3 il: 01 Agosto 2014, 17:36:38 CEST »
0
Perfetto. Ci provo e ti aggiorno. Però vorrei farti una domanda: con minsdk=froyo vuol dire che l'applicazione che intendo creare necessita di almeno un sistema 2.2 giusto?mentre con target imposto il sistema su cui l'applicazione viene implementata. Non ho capito il significato del campo compile, ho provato ad impostare froyo anche lì ma non mi permette di andare avanti e quindi sono obbligato a mettere wear come mai?

* l'app funziona sui sistemi con API>=minSDK e non supporta quelli con API<minSDK
* l'app è stata pensata e testata per API=targetSDK e per tutte le altre API vengono eventualmente usate soluzioni di compatibilità
* l'app è stata compilata usando la versione di runtime con API=compilewith

Nella stragrande maggioranza dei casi minSDK=12 (ma sta scomparendo) oppure minSDK=14.
E solitamente targetSDK = compilewith = ultima versione stabile
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline astro87

  • Nuovo arrivato
  • *
  • Post: 21
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    motorola moto g
  • Sistema operativo:
    windows 7
Re:appcompat_v7
« Risposta #4 il: 01 Agosto 2014, 17:44:38 CEST »
0
Ho effettuato le operazione che mi hai suggerito ed effettivamente funziona :).
Ti ringrazio di tutto....ora posso finalmente mettermi al lavoro