Autore Topic: MAVEN no dependency information available  (Letto 425 volte)

Offline Caco85

  • Nuovo arrivato
  • *
  • Post: 15
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Motorola moto g
  • Sistema operativo:
    Windows 7
MAVEN no dependency information available
« il: 02 Luglio 2014, 10:03:38 CEST »
0
Ciao a tutti,
Ho creato un progetto maven per appengine, ma quando eseguo il comando: mvn appengine:update
ricevo il seguente errore:

C:\Users\Caco\AndroidStudioProjects\Sand Messages Server\SandMessagesServer\SandMessagesServer-ear>m
vn appengine:update
[INFO] Scanning for projects...
[INFO]
[INFO] Using the builder org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBu
ilder with a thread count of 1
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building SandMessagesServer-ear 1.0
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] >>> appengine-maven-plugin:1.9.6:update (default-cli) @ SandMessagesServer-ear >>>
Downloading: http://repo.maven.apache.org/maven2/com/caco/sandmessagesserver/SandMessagesServer-war/
1.0/SandMessagesServer-war-1.0.pom
[WARNING] The POM for com.caco.sandmessagesserver:SandMessagesServer-war:war:1.0 is missing, no depe
ndency information available
Downloading: http://repo.maven.apache.org/maven2/com/caco/sandmessagesserver/SandMessagesServer-war/
1.0/SandMessagesServer-war-1.0.war
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.466 s
[INFO] Finished at: 2014-07-02T09:38:51+01:00
[INFO] Final Memory: 9M/245M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project SandMessagesServer-ear: Could not resolve dependencies for
 project com.caco.sandmessagesserver:SandMessagesServer-ear:ear:1.0: Could not find artifact com.cac
o.sandmessagesserver:SandMessagesServer-war:war:1.0 in central (Directory Browsing Disabled)
 -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following arti
cles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
"cmd" non è riconosciuto come comando interno o esterno,
 un programma eseguibile o un file batch.

Posto i file pom.xml:

Codice (XML): [Seleziona]
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
  <modelVersion>4.0.0</modelVersion>

  <groupId>com.caco.sandmessagesserver</groupId>
  <artifactId>SandMessagesServer-ear</artifactId>
  <version>1.0</version>
  <packaging>ear</packaging>

  <parent>
    <groupId>com.caco.sandmessagesserver</groupId>
    <artifactId>SandMessagesServer</artifactId>
    <version>1.0</version>
  </parent>

  <build>
    <plugins>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-ear-plugin</artifactId>
        <version>2.8</version>
        <configuration>
          <version>5</version>
          <defaultLibBundleDir>lib</defaultLibBundleDir>
          <unpackTypes>war</unpackTypes>
        </configuration>
      </plugin>
      <plugin>
        <groupId>com.google.appengine</groupId>
        <artifactId>appengine-maven-plugin</artifactId>
        <version>${appengine.target.version}</version>
      </plugin>
    </plugins>
  </build>

  <dependencies>
    <dependency>
        <groupId>com.caco.sandmessagesserver</groupId>
        <artifactId>SandMessagesServer-war</artifactId>
        <version>1.0</version>
      <type>war</type>
    </dependency>

  </dependencies>
</project>


Codice (XML): [Seleziona]
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">

    <modelVersion>4.0.0</modelVersion>
    <packaging>war</packaging>
    <version>1.0</version>
    <groupId>com.caco.sandmessagesserver</groupId>
    <artifactId>SandMessagesServer-war</artifactId>

    <parent>
        <groupId>com.caco.sandmessagesserver</groupId>
        <artifactId>SandMessagesServer</artifactId>
        <version>1.0</version>
    </parent>

    <properties>
        <appengine.app.version>1-war</appengine.app.version>
        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    </properties>

    <dependencies>
        <!-- Compile/runtime dependencies -->
        <dependency>
            <groupId>com.google.appengine</groupId>
            <artifactId>appengine-api-1.0-sdk</artifactId>
            <version>${appengine.target.version}</version>
        </dependency>
        <dependency>
            <groupId>org.json</groupId>
            <artifactId>json</artifactId>
            <version>20140107</version>
        </dependency>

        <dependency>
            <groupId>javax.servlet</groupId>
            <artifactId>servlet-api</artifactId>
            <version>2.5</version>
            <scope>provided</scope>
        </dependency>
        <dependency>
            <groupId>jstl</groupId>
            <artifactId>jstl</artifactId>
            <version>1.2</version>
        </dependency>

        <!-- Test Dependencies -->
        <dependency>
            <groupId>com.google.appengine</groupId>
            <artifactId>appengine-testing</artifactId>
            <version>${appengine.target.version}</version>
            <scope>test</scope>
        </dependency>
        <dependency>
            <groupId>com.google.appengine</groupId>
            <artifactId>appengine-api-stubs</artifactId>
            <version>${appengine.target.version}</version>
            <scope>test</scope>
        </dependency>
    </dependencies>
     
    <build>
        <outputDirectory>target/${project.artifactId}-${project.version}/WEB-INF/classes</outputDirectory>
                                   
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-war-plugin</artifactId>
                <version>2.3</version>
                <configuration>
                    <archiveClasses>true</archiveClasses>
                    <webResources>
                        <!-- in order to interpolate version from pom into appengine-web.xml -->
                        <resource>
                            <directory>${basedir}/src/main/webapp/WEB-INF</directory>
                            <filtering>true</filtering>
                            <targetPath>WEB-INF</targetPath>
                        </resource>
                    </webResources>
                </configuration>
            </plugin>
        </plugins>
    </build>

</project>

Codice (XML): [Seleziona]
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
  <modelVersion>4.0.0</modelVersion>
  <groupId>com.caco.sandmessagesserver</groupId>
  <artifactId>SandMessagesServer</artifactId>
  <version>1.0</version>
  <packaging>pom</packaging>
 
  <properties>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    <appengine.target.version>1.9.6</appengine.target.version>
  </properties>

  <build>
      <pluginManagement>
          <plugins>
              <plugin>
                  <groupId>com.google.appengine</groupId>
                  <artifactId>appengine-maven-plugin</artifactId>
                  <version>${appengine.target.version}</version>
              </plugin>
          </plugins>
      </pluginManagement>
  </build>
  <modules>
    <module>SandMessagesServer-war</module>
    <module>SandMessagesServer-ear</module>
  </modules>
</project>

Avete idea di come risolvere questo errore?
Grazie in anticipo.