Autore Topic: Debug\ Release  (Letto 479 volte)

Offline Maluma1

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
Debug\ Release
« il: 12 Maggio 2014, 08:39:17 CEST »
Salve, qualcuno saprebbe spiegarli come mai la mia applicazione in versione debug funziona senza alcun problema mentre la versione Release funziona differentemente? (L'unica cosa che ho cambiato è stata la spunta su Release)

Inviato dal mio Nexus 5 utilizzando Tapatalk

« Ultima modifica: 12 Maggio 2014, 12:12:42 CEST da Maluma1 »

Offline eagledeveloper

  • Translate Team
  • Utente senior
  • ****
  • Post: 516
    • Google+
    • 347516210
    • dark_pinz
    • @WandDStudios
    • Mostra profilo
    • W&D Studios
  • Dispositivo Android:
    HTC One X e HTC One
  • Play Store ID:
    W%26D+Studios
  • Sistema operativo:
    Ubuntu / Windows 7
Re:Debug\ Release
« Risposta #1 il: 12 Maggio 2014, 09:40:58 CEST »
Potrebbe essere un problema di obfuscation. Quando firmi l'applicazione con la chiave di release viene usato un file (proguard.txt) per offuscare il codice. In certi casi offusca "troppo" e ti ritrovi dei ClassNotFound o roba del genere. Prova a guardare il logcat e vedere cosa ti dice.
I numeri contano molto di più del seme.

Offline Maluma1

  • Nuovo arrivato
  • *
  • Post: 15
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
Re:Debug\ Release
« Risposta #2 il: 12 Maggio 2014, 11:40:48 CEST »
Grazie mille.. Proverò!!

Inviato dal mio Nexus 5 utilizzando Tapatalk