Autore Topic: Problema listview scrolling...  (Letto 303 volte)

Offline roxdragon

  • Nuovo arrivato
  • *
  • Post: 22
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Galaxy S3
  • Sistema operativo:
    Ubuntu 10.04
Problema listview scrolling...
« il: 16 Aprile 2014, 18:32:06 CEST »
0
Salve ragazzi è da qualche giorno ma non ne sono riuscitoa  venire a capo...
ho una listview... tutto funziona... ma quando provo a scorrere dal basso verso l'alto ecco cosa succede..

Imagebin - A place to slap up your images. se scrollo dal basso verso l'alto : Imagebin - A place to slap up your images. mentre viceversa  mi appare l'aura blu come per dire che sono gia all'inizio.. Grazie..

in un fragment:
Codice (XML): [Seleziona]
<?xml version="1.0" encoding="utf-8"?>
<RelativeLayout xmlns:android="http://schemas.android.com/apk/res/android"
   android:layout_width="fill_parent"
   android:layout_height="fill_parent" >

    <ListView
       android:id="@+id/listView1"
       android:layout_width="match_parent"
       android:layout_height="wrap_content"
       android:layout_alignParentLeft="true"
       android:layout_alignParentTop="true"
                android:cacheColorHint="#00000000" />  

</RelativeLayout>

Offline GabMarioPower

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 606
  • Respect: +153
    • Github
    • Google+
    • gabrielemariotti
    • GabMarioPower
    • Mostra profilo
  • Play Store ID:
    GAB+MARIO+DEV
  • Sistema operativo:
    Ubuntu 14.04 , Win 10
Re:Problema listview scrolling...
« Risposta #1 il: 17 Aprile 2014, 09:58:07 CEST »
0
Onestamente non sono riuscito a capire il problema dalle immagini.

In ogni caso:
Codice (XML): [Seleziona]
<ListView
      android:layout_height="wrap_content"

MAI usare il wrap_content sull'altezza della listView!

Offline roxdragon

  • Nuovo arrivato
  • *
  • Post: 22
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Galaxy S3
  • Sistema operativo:
    Ubuntu 10.04
Re:Problema listview scrolling...
« Risposta #2 il: 17 Aprile 2014, 10:30:48 CEST »
0
Ciao ho risolto usando baseAdapter...
si infatti già l'avevo cambiato..adesso funziona! Grazie ancora...
ne approfitto per fare una domanda...
Avendo due fragment... posso usare un custom_row.xml uguale per entrambi i fragment? quindi usare CustomBaseAdapter unico anche ma passando diversi valori?
Grazie