Autore Topic: Errori continui in emulazione  (Letto 511 volte)

Offline MaD

  • Nuovo arrivato
  • *
  • Post: 8
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Sistema operativo:
    Windows 8
Errori continui in emulazione
« il: 21 Febbraio 2014, 23:59:24 CET »
0
Ciao ragazzi, premetto, sono un neofita in ambiente Android :-)

Volevo far partire una semplice applicazione, di sola interfaccia, senza alcuna mia modifica ma quando tento di effettuare il run mi compaiono alcuni errori:

Codice: [Seleziona]
[2014-02-22 23:56:02 - Buona] Android Launch!
[2014-02-22 23:56:02 - Buona] adb is running normally.
[2014-02-22 23:56:02 - Buona] Performing com.emple.buona.MainActivity activity launch
[2014-02-22 23:56:02 - Buona] Automatic Target Mode: Preferred AVD 'AVD_for_Nexus_4_by_Google' is not available. Launching new emulator.
[2014-02-22 23:56:02 - Buona] Launching a new emulator with Virtual Device 'AVD_for_Nexus_4_by_Google'
[2014-02-22 23:56:03 - Emulator] Failed to allocate memory: 8
[2014-02-22 23:56:03 - Emulator]
[2014-02-22 23:56:03 - Emulator] This application has requested the Runtime to terminate it in an unusual way.
[2014-02-22 23:56:03 - Emulator] Please contact the application's support team for more information.

Potrei avere delucidazioni? Grazie mille ragazzi!:)

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Errori continui in emulazione
« Risposta #1 il: 22 Febbraio 2014, 11:00:58 CET »
0
Invece di lanciare l'emulatore quando cerchi di lanciare l'app, apri la finestra con gli AVD e avvia "a mano" quello che vuoi usare. Vedi cosa ti dice.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline MaD

  • Nuovo arrivato
  • *
  • Post: 8
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Sistema operativo:
    Windows 8
Re:Errori continui in emulazione
« Risposta #2 il: 22 Febbraio 2014, 14:37:19 CET »
0
Invece di lanciare l'emulatore quando cerchi di lanciare l'app, apri la finestra con gli AVD e avvia "a mano" quello che vuoi usare. Vedi cosa ti dice.

Non me lo faceva lanciare; ho risolto abbassando il quantitativo di ram del dispositivo virtuale, portandolo a 512 mb.

Ti ringrazio comunque!  :-)